Oh-oh, lost my web site :(

Permalink
Hi! I was upgrading to the latest version of concrete5 and the upgrade stopped or stalled. When I went back to the start over, my home page is blank or not loading. Don't know where to start to recover.

Thanks!

Joe

View Replies: View Best Answer
WillemAnchor replied on at Permalink Reply
WillemAnchor
Hi jbrew2,

Sorry to hear that.

Before anyone can help you, some more info is needed:
- do you have a back-up (database AND files)
- does your host have a back-up
- what's the original version of concrete5 (before the backup started)
- what version did you try to upgrade to

Also please read the following to check what other info you can provide:http://documentation.concrete5.org/tutorials/tips-getting-forum-que...
jbrew2 replied on at Permalink Reply
Good day Willem and Thank you! I'll re-state the problem with additional information:

While I was updating to the latest Concrete5 update today, I think its 5.3.4, but not sure at all the update stopped or stalled. When I reloaded my home page, all I get is a white page. I am not getting an error message. The application will not load to clear the Cache. I am using Mac iOS 10.11.2, Safari 9.0.3 with a clean Browser and have also tried FireFox. My website address iswww.www.brunettifamily.org/family/.... This is the Browser errors from the console:

[Warning] Unexpected CSS token: : (font-awesome.css, line 4)
[Warning] Unexpected CSS token: : (font-awesome.css, line 4)
[Warning] Unexpected CSS token: : (font-awesome.css, line 4)
[Warning] Unexpected CSS token: : (font-awesome.css, line 4)
[Warning] Invalid CSS property declaration at: * (jquery.ui.css, line 1)
[Warning] Invalid CSS property declaration at: * (jquery.ui.css, line 286)
[Warning] Unexpected CSS token: : (jquery.ui.css, line 287)
[Error] Failed to load resource: the server responded with a status of 404 (HTTP/2.0 404) (bg_avatar_blue_right.png, line 0)

And this is my host error log from MacHighway:

[09-Apr-2016 17:21:34 UTC] PHP Warning: require(/home/brunetti/public_html/family/updates/concrete5.6.3.4/concrete/dispatcher.php): failed to open stream: No such file or directory in /home/brunetti/public_html/family/concrete/startup/updated_core_check.php on line 6
[09-Apr-2016 17:21:34 UTC] PHP Fatal error: require(): Failed opening required '/home/brunetti/public_html/family/updates/concrete5.6.3.4/concrete/dispatcher.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/brunetti/public_html/family/concrete/startup/updated_core_check.php on line 6

I have all my Data files but I don't think I have any of web files unless they are saved last year during the last upgrade.

That do you think? Any hope?
Joe
WillemAnchor replied on at Permalink Best Answer Reply
WillemAnchor
Hi jbrew2

I didn't touch a legacy (< 5.7) site for some time, and don't have a lot of time to dig into this again.
But...well let's see.

First of all, make a copy of the current system: database and important files.

I don't know why the upgrade failed, but possibly the new version was to big of a step and needed a lower version first. You talk about version 5.3 and the errors say 5.6.3.4
Or maybe you had prettyURLs enabled ?

I also don't know where the update halted.
I'll give you a few leads:
- your config/site.php file may have something like:
<?php define('DIRNAME_APP_UPDATED', 'concrete5.6.3.4');?>
in it.
That would be the last updated version
- your /concrete/version.php holds the initial version
- your /updates directory holds the different updates
- your database also holds a version
With these you should be able to figure out the current situation and what to do next.

As a last resort...
You have a backup from a year ago...does it include the database and at least the following files:

files/
packages/
updates/
config/

Then you could try to restore this version. The process is about the same as moving a site. Have a good read here:http://legacy-documentation.concrete5.org/developers/installation/m...
jbrew2 replied on at Permalink Reply
Thanks again. I'm looking at my host files and I see the all what you discussed as well as the Backup from last year. It looks like a very large SQL file. I submitted ticket to them for help to see what they can do. I have all my data files backed up locally but some web pages I didn't archive. I think I see all the backup webpages in the server files folder.

Thanks again

Joe
jbrew2 replied on at Permalink Reply
I like to close out this thread with some good news, a big thanks to Willem for the education of where all Install & backup files go and some tech support help to restart the upgrade. The issue was a stall of the upgrade when some core files didn't transfer to my host. Lessons are learned to back up not just the data files but also the web pages. Thanks again!

Joe
WillemAnchor replied on at Permalink Reply
WillemAnchor
good the hear it's solved !
mason203 replied on at Permalink Reply
You need the data stored in the SQL database, the files themselves wont contain the data you need.