PHP imagick error: cannot open shared object file: No such file or directory

Permalink 1 user found helpful
Hello!

I'm getting an error on my Concrete 5 site:

An unexpected error occurred.

PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20100525/imagick.so' - libMagickWand.so.2: cannot open shared object file: No such file or directory.

Any ideas on what might be causing this and how I might go about fixing it?

I'm hosting on Godaddy. I did call them up and talk to a tech support rep who suggested that "a script is calling for a file that is not actually located inside the server" and that I should "tell my script to look for the file in a different location."

Given that I didn't write any scripts (hah) for the site, I'm not sure where to start. I've looked through and identified various files inside the Concrete installation that use Imagick (mode-php.js, FileServiceProvider.php, Image.php, autoload_classmap.php, installed.json, etc.). But none have obvious "paths" to me that seem to be pointing at something it shouldn't, and there is no reference in the site to "imagick.so" that I can find. Then again, I'm also more of a designer and not all that familiar with PHP.

Additionally, I'm able to follow the path myself while FTPing. "'/usr/local/lib/php/extensions/no-debug-non-zts-20100525/imagick.so" and can find the file without any trouble.

The only other thing I can thing of is that we recently consolidated hosting for this site with several other websites I manage. This site become situated in a folder lower (public_html/thiswebsite.com). However, I did restore the site from a backup and it seemed to work fine and I've made no major edits to the site since then outside of making some content updates.

The other interesting thing is that this error only occurs about half the time. If, for example, I visit the site, get the error, and hit refresh, the error goes away and the site works as it should. If you wish to see for yourself, visit: http://joshuaviola.com . Try alternating things like typing the URL of the site in, refreshing, etc. One of those should get the PHP error to show. I've also had it show up when editing my site in the C5 editor.

I'm presently running Concrete 5.7.5.2 with the Brimstone Theme 2.1.4 and Easy Image Gallery 1.3.1.

Any help in tracking this down would be greatly appreciated!

View Replies: View Best Answer
MrKDilkington replied on at Permalink Best Answer Reply
MrKDilkington
Hi ResidentNinja,

Based on the release notes, you might want to try updating to 5.7.5.3.

"We now default to the “GD” image processing library for image manipulation. Imagick must be opted into by setting the config value “concrete.file_manager.images.manipulation_library” to “imagick”."
http://documentation.concrete5.org/developers/background/version-hi...
ResidentNinja replied on at Permalink Reply
Awesome, thank you! I've just upgraded to 5.7.5.3 and I'm not seeing the error. I'll keep an eye on it and report back after I've seen it in action for a bit.

Thanks again!
ResidentNinja replied on at Permalink Reply
Looks to have solved the issue. Thanks so much!
leinteractive replied on at Permalink Reply
leinteractive
I'm getting the same error on version 5.7.5.6. Although it only happens occasionally.

php startup unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20100525/imagik.so' - IoMagikWand.so.2: cannot open shared object file: No such file or directory

I'm using GoDaddy's shared hosting and feel that may be creating a conflict. Any ideas?
Mnkras replied on at Permalink Reply
Mnkras
That error is a PHP error that is out of concrete5's hands, I would suggest contacting godaddy support for that.