Problem with migration from Windows to Linux

Permalink 1 user found helpful
Hi!, I have to mount a production environment from Windows using XAMP to Centos. First problem was the case sensitive names of tables, that what solved by renaming the tables.

When I want to login into the project, a get this error:

PHP Fatal error: Call to a member function getSiteTreeID() on null in /var/www/html/observatorio/concrete/src/Page/PageList.php on line 183, referer:http://192.168.100.19/observatorio/index.php/login...

Please help me with this!. I have lost!

View Replies:
mandres replied on at Permalink Reply
Any ideas?, please help me!, I dont want to change this CMS!
Gondwana replied on at Permalink Reply
Gondwana
The problem sounds vaguely familiar, but I can't find why. The only thing I can find that's close is
https://www.concrete5.org/community/forums/usage/missing-sitetree-ca...

You could try different methods for copy your database across; I've heard that some methods (options) can omit things.

There's also a chance that foreign key capitalisation is a problem.

I wasn't able to access the URL you provided; could it be for a computer on your home network?
mandres replied on at Permalink Reply
Hi!. thanks for your responses!. The problem was solved by renaming entire database according the "root/concrete/config/db.xml" file.

Important to trace the correct name of entities using developer tools like Firebug!.
A3020 replied on at Permalink Reply
A3020
I've had this error as well but then in combination with Cloudflare. After I moved away from Cloudflare the problem was gone. Maybe it's related to https / canonical url / htaccess.