Problem with folders


I'm trying to install a new web in a windows server but I've got some problems:
- First of all, I copy a new folder with the Concrete files at the server via ftp.
- Then, create a DB to link to the web.
- After that, type the adress of the web in the browser and can see the installation page where I insert the data of my server, DB, etc.
- But when I click the button to start the automatic installation, got some errors:

PHP Warning: mkdir() [<a href='function.mkdir'>function.mkdir</a>]: Permission denied in D:\MyWeb\concrete\controllers\install.php on line 154/157/160/163/166

And the installation stops and leaves me with an incomplete DB (only 35 tables).
I have permissions to write at the server, any ideas?

Thank you!

View Replies:
Remo replied on at Permalink Reply
I'm quite sure this is a permission problem. Who's the owner of the directory files? IUSR..?

It's a bit annoying that c5 creates the tables even if it fails to install, but I think this has been reported before..

Means you have to drop all the tables in the db before you can try installing it again!
AlbertoB replied on at Permalink Reply
I think that's exactly the problem.
I'm connecting with a username to upload files to the server via ftp(that's the way I copied the C5 files into it).
But when I try to install C5, I have to introduce the DB owner, who is a different user.
I'm really lost with this one because I'm not used to mess with servers.
Remo replied on at Permalink Reply
I'm not sure if I get it right but the db user doesn't matter. The user who executes the webserver and the user who owns your directories are the two you should check..
AlbertoB replied on at Permalink Reply
Sorry but think i don't get you when you say "the user who executes the webserver".

You mean the one trying to install C5? I'm doing that directly from the browser...
ScottC replied on at Permalink Reply
That the db user that has access to the db is agnostic, IE the db doesn't care nor should it of the name of the user that is accessing the db as long as they have the correct permissions to do whatever you want to do on the db IE create tables and write to them and whatnot :) Kind of like chmod 777 for the files directory etc :)

Think ftp user for your site being the same as a db user to your db
efripp replied on at Permalink Reply
Did anyone find a solution to this? I'm experiencing the same thing. I changed permissions for all files and folders in ../concrete to 777. Permissions for .../3rdparty/adodb/ are 777. Also tried: I created a mysql user (with all permissions) identical to the user who copied the folders to /var/www/. Now the during the installation page I input the new user and I get "unable to connect to database", like the new user doesn't have access to the database. I'm new to MySQL though so it's probably a rookie mistake. Additionally, even when I get the user to work I'll probably run into the same error again, but it's worth a shot. Any suggestions?
andrew replied on at Permalink Reply
In the root directories? They need to be 777. Nothing else needs to be.

If they are, then there may be something in your PHP install that is making it so that mkdir() is disabled... Which is strange...