Save/Edit Button Stopped Working On Block Edits

Hello! I have a site I put together on Concrete, using a simple custom theme

I made based off Skeleton. Everything worked fine but now the Save or Edit button in

the Block Edit Mode box will not do anything. It seems to work using a default

theme, but not with my custom one. It worked before, and now nothing.

It gave me no problems until recently, and I'm struggling to see what could have

happened to cause this. I even tried a fresh install, then uploaded and installed my

theme, and now it won't let me Add a block. Absolutely everything else works fine,

except Save, Edit, Add and also the Upload button in the File Manager. I can use the

multi-file uploader fine, but the single file Upload button doesn't work.

Everything was working previously, and everything in the Dashboard works fine, popups

save properly, etc. I checked the console for errors on the button, but nothing

really came up. One button had an error about the typography.css file being missing,

but even by placing one in my theme dir it made no difference, still couldn't save


View Replies: View Best Answer
mnakalay replied on at Permalink Reply
First I strongly suggest you don't leave your site admin password on a public forum as you are putting it at great risk. If I were you I would delete it quickly from here and modify it on your website.

Concerning your problem:
You are loading jquery 1.11.1, then a script bm-plugins.js, then Concrete5 is loading another version of jquery.

That most likely creates the problem.

You have 2 choices:
1- you don't load your own jquery, just use C5's one and load your script after Jquery
2- You absolutely need your own jquery so load it but make sure that when in edit mode you don't load it and allow C5 to load its own.
JayCadilak replied on at Permalink Reply
Thanks for the reply and concern. I have a few installs of this, not concerned if someone does something. I will follow your suggestion, however.

I suspected a jQuery conflict, so I actually removed the call for both of those files completely and it seems that the problem is still there. It exists on my localhost, the above hosting service, and another hosting service. I installed a fresh, clean installation of Concrete5 and only installed my theme - no content and no addons, etc. And it wouldn't let me click "Add" to add a new block. The Add/Edit block dialog pops up, everything works within it, just not the blue Add/Save/Edit button. Brain damage.

Thanks again.
hutman replied on at Permalink Reply
There are other people running who are having the same problem.
JayCadilak replied on at Permalink Reply 1 Attachment
Just tried a fresh install on and same issue. I've attached my theme folder if someone wants to have a look. This default.php has been simplified to exclude any jQuery, as I thought it was a conflict but removing the jQuery didn't seem to help at all.
JayCadilak replied on at Permalink Reply
Things get stranger. So I actually rebuilt the theme, testing on my localhost as I went to make sure I retained editability. Everything was great, and I could add content to the blocks as normal.

When I got all the blocks in place, I could still edit and save, etc. So I put a fresh install on the live server, installed my theme, and when I went to add a new block I couldn't save.

So I flipped back to the window with the localhost installation, and tried editing and what do you know - I now cannot save/add the block.

Could this be something with my machine or browser? I am using Chrome, although I've tested in IE and same result. I'm ready to blame supernatural forces.
JayCadilak replied on at Permalink Best Answer Reply
Problem solved. For reference, the problem here was a z-index setting in the CSS. The contact form Submit button on this page requires a high z-index setting, and that setting made the blue Add/Edit/Save button unresponsive. I just used PHP to change it to z-index:0 while in edit mode.

In retrospect, I applied the settings to input[type="submit"] whereas I probably could have avoided the issue by using a class name. But I'm moving on haha.

Thanks for the assistance guys.