should index.php appear in the URL ?

Permalink
ever since i upgraded from 5.4.1.1 to 5.4.2.1 myurl links screwed up. i had to rename concrete directory and restore the previous version. i noticed when clicking on a header item the URL would have index.php
e.g. mysite.com/concrete/index.php/services
now this works but its screwing up our google adwords adverts as index.php wasn't used before.
while on 5.4.2.1 url would be : mysite.com/concrete/servises but now the page is not found

any ideas how to fix this ??
thanks in advance for any suggestions

View Replies: View Best Answer
wagdi replied on at Permalink Best Answer Reply
wagdi
You may need to enable pretty url's again.

"Enabling Vanity URLs / Pretty URLs

If you care about Search Engine Optimization (SEO) you should consider turning on Pretty URLs. This turns a geeky looking web address like:

http://www.concrete5.org/index.php?cID=32271

into something like:

http://www.concrete5.org/areaname/pagename


To enable Pretty URLs, login to your concrete5 instance as the Admin user, and goto Dashboard > Sitewide Settings. There's an option on the right of that page which you can turn on. You may also have to create a .htaccess file on your sever for this to work right, the Dashboard will provide the details for that file."

SOURCE: http://www.concrete5.org/documentation/installation/installing_conc...
wissam replied on at Permalink Reply
Thanks Wagdi. this seems to fix it on 5.4.2.1 but 1 more thing hope you can help me with, the company logo disappeared. i copied the image file into /concrete/themes/default/images
anything else i need to do ?
wagdi replied on at Permalink Reply
wagdi
Sure..

1. Login into your website as admin>>
2. Go to Dashboard>>
3. Scrapbook>>
4. Global Scrapbook>>
5. Edit>>
6. You should see a wysiwyg where you can edit the name or add an image.
wissam replied on at Permalink Reply
Thanks,, but there are no items in the global scrapbook.. any ideas ??
cannonf700 replied on at Permalink Reply
cannonf700
you might have to manually make either a content block or an image block in your global scrapbook and then rename is My_Site_Name
Albin replied on at Permalink Reply
I had the same issue. I was getting 404 errors. I turned on Pretty URLs and the problem went away. I guess at some point I had them on and forgot that I turned them off.

Thanks for the tip
jordanlev replied on at Permalink Reply
jordanlev
You may also need to add this to your config/site.php file:
define('URL_REWRITING_ALL', true);
wissam replied on at Permalink Reply
.
SpencerC replied on at Permalink Reply
SpencerC
You also may need to add the .htaccess file to your directory. It has never appeared automatically in mine. This is more for future reference of other users than to solve your issues.

1) Create a new file titled .htaccess in a plain text program.
2) Copy and paste the code from the Dashboard (available after you click "enable pretty urls"
3) Save the file and upload to the root folder: yoursite/.htaccess


That should do it.
acuvic replied on at Permalink Reply
I've tried all the suggestions but still get the "index.php" in my path - ie. "http://lichfieldtherapy.co.uk/index.php/treatments"

Can anyone help to make the browser address bar show "http://lichfieldtherapy.co.uk/treatments" instead?
acuvic replied on at Permalink Reply
Uh .... solved it. Just remove the "index.php" in the <a href definition in html edit mode of the linking page.

ie. Change
<a title="Treatments" href="{CCM:BASE_URL}/index.php/treatments">
to
<a title="Treatments" href="{CCM:BASE_URL}/treatments">