Site broken after moving to different server

Hi. I'm developing a site on a local VirtualBox server. It works fine, but I'm trying to move it to a different VirtualBox server with a larger harddisk. I've tried following the "move site" instructions several times, but the same thing happens every time. Most pages are blank and some are visible but truncated and missing images. For some pages, the Edit bar is visible, for others it is not. There are no error messages, just a messy site.

I placed the working site in maintenance mode before exporting the concrete5 database and copying all the files to the new one, and importing the sql file there. I've emptied the files/cache and files/tmp folders, and chwon'ed all folders to www-data:www-data (the apache2 user) The working site is version, and uses the Greek Yoghurt theme. Both servers are Ubuntu 12.04.2 32-bit server edition.

I'm a bit lost here. Could someone please point me in the right direction?


Oslo, Norway
P.S. I've attached the environment information.

1 Attachment

View Replies:
MoonGrab replied on at Permalink Reply
Well that's weird. Your memory limit (which is usually the case) seems fine.
Could you maybe give me some access so I can investigate the issue?

Also, try disabling, then clearing the cache.
After that, backup your database via phpmyadmin and finally transfer the files.
See if that makes any difference. If all the pages are blank in that case, that's also a good thing. We are trying to achieve a global effect here, not something that happens randomly.

Also, open up your /etc/apache2/apache2.conf file and add
FcgidMaxRequestLen 20000000
to the bottom of it (if you don't already have that propery). If I'm right, it won't have any effect because you don't seem to be running php in fcgi mode, but as an apache module. So that suggestion is only here to clear up some questions.
hallaeru replied on at Permalink Reply
Thanks for your help, MoonGrab! I'd gladly give you access, but the virtual server is on a personal pc behind a router with dynamic IP address. I don't think you would be able to reach it. I could zip the files and give you access to them via dropbox? The site has got a lot of images and sound files, so it is perhaps not a feasible option.

The cache on the broke site was disabled (as it was on the working site), and clearing it made no change.

I tried the FcgidMaxRequestLen trick, and got the following result when restarting apache:
ubuntuConcrete5>: sudo /etc/init.d/apache2 restart
Syntax error on line 239 of /etc/apache2/apache2.conf:
Invalid command 'FcgidMaxRequestLen', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.!

That seems to be something else than expected?

hallaeru replied on at Permalink Reply
Solved it..or at least, found a workaround! I just installed a virtual debian server, did all the LAMP installation stuff, including php5-gd and php5-mysql libraries. Copied site and restored the sql dumpfile, and everything worked like a charm.
hallaeru replied on at Permalink Reply
Hi Moongrab. I think I found the root of this problem. It appears to be a missing php5-gd.. It is of course easiest spotted by installing a new concrete5 site on your host.