Site Down with GoDaddy - at wits end....

Permalink 5 users found helpful
Hi - any help greatly appreciated with the following issue - we cannot access anything on our web sitehttp://www.evolutionri.com, other than the home page. We can't even access the CMS login.

We host our site with GoDaddy (linux hosting). Recently GoDaddy upgraded apache and now our site is not accessible - we get the error message "no input file specified." In the go daddy support forums they acknowledged issues with the mod_rewrite and an apache update to 2.4; php is 5.3

We disabled pretty urls -- the only result was "404 error" replaced the "no input file specified" message I can't even see what version of Concrete 5 is running but it is not far behind - installed in fall of 2012.

GoDaddy disabled fast cgi – and they also tried editing the php5.ini file – both with no results.

Also -- GoDaddy recently removed the file extension manager from the hosting control panel (if you could call it that) and that has to be done via the htaccess file --- This fix was cited in several places. Perhaps this is why handlers were added to the htaccess by GoDaddy support, which obviously didn't solve the issue.

Since GD support fiddled with a "solution", I see that the styles have now dropped and so its not accessing the css or theme which makes me wonder if it has to do with the rewrite base - I just don't understand why it worked and now suddenly it doesn't any more.

We don't know what to do -- GoDaddy doesn't know what to do. Any help anyone can offer is greatly appreciated.

View Replies:
madeforspace replied on at Permalink Reply
madeforspace
I saw another thread a while ago about a similar issue, it may help.
http://www.concrete5.org/community/forums/customizing_c5/no-input-f...
Blenderite replied on at Permalink Reply
Blenderite
From what I have heard, GoDaddy is not a good hosting service. I would probably switch to something like Arvixe or BlueHosting.
5fly replied on at Permalink Reply
5fly
EvolutionPilates replied on at Permalink Reply
thanks for your responses - been pulling my hair out

I did try these fixes and unfortunately they didn't work. I'm thinking that moving the site might be the fastest solution at this point.

Here is the current htaccess file (GoDaddy's latest attempt to resolve the issue):

ErrorDocument 404 default
addhandler x-httpd-php-cgi .php4
addhandler x-httpd-php5-cgi .php
addhandler x-httpd-php5-cgi .php5
# -- concrete5 urls start --
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule ^(.*)$ index.php?/$1 [QSA,L]
</IfModule>
# -- concrete5 urls end --
EvolutionPilates replied on at Permalink Reply
thanks for your responses - been pulling my hair out

I did try these fixes and unfortunately they didn't work. I'm thinking that moving the site might be the fastest solution at this point.

Here is the current htaccess file (GoDaddy's latest attempt to resolve the issue):

ErrorDocument 404 default
addhandler x-httpd-php-cgi .php4
addhandler x-httpd-php5-cgi .php
addhandler x-httpd-php5-cgi .php5
# -- concrete5 urls start --
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule ^(.*)$ index.php?/$1 [QSA,L]
</IfModule>
# -- concrete5 urls end --
anedix replied on at Permalink Reply
Hi,

I had the same exact problem, I came up with a temporary work-a-round.
My .htaccess file looks like this for now (back yours up before doing the below):
# -- concrete5 urls start --
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^(default.htm)/?$ index.php
RewriteRule ^(default.html)/?$ index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ http://%{HTTP_HOST}/index.php/$1 [L]
</IfModule>
tabercreative replied on at Permalink Reply
tabercreative
This has my site back up and all the links functioning. Thank you so much!

The problem now is that the URLs are generating with "/index.php/" between the domain and the page. Have you or anyone else discovered a way to remove that (as it was before in my case)?
rainmaker replied on at Permalink Reply
rainmaker
Hey tabercreative -- same thing happened to me as well. They keep blaming us.

Anedix - Thanks for the fix! :) If anyone else can figure out how to do it without the index.php, I'd love to know as well. For now though, this totally works!!!

Thanks!
tabercreative replied on at Permalink Reply
tabercreative
This is extremely frustrating. There was absolutely nothing wrong with this site on Tuesday, and no changes were made at all before it went down.

GoDaddy originally claimed it was an issue with an Apache update on their end. They escalated the case, then came back to me with the following response...

"I can duplicate the issue; as the home page loads but any subsequent links give a Page Not Found error. The redirects in your .htaccess file are working, but the page that they are suppose to bring up is not getting fetched from your database. I took a look at the database that you are using for this site to see if I could find out why your permalinks aren't working properly. Based on your "Pages" table it appears that the pages have no data. At this point I cannot troubleshoot further and believe the issue is a result of your application and not the server. Because of this I recommend reviewing the support available for Concrete to determine a fix in your application."
dknzdesign replied on at Permalink Reply
We have he same EXACT problem.
goDaddy sucks, I can't believe they would do this and not tell us.
I used the solution before for this problem of using the File Extension Manager also. But now they have taken this tool away and chnaged the php version without any notice.
Now we also have no backend access, unless erase index.php everytime from the URL and that doesn't work if you want to save most changes as they are saved Asynchronously.
I tried the .htacess change AND the php5.ini change and NOTHING
Anyone gives aus a hand!

PS
Why doesn't one of the bigests webhosts in the world provide support for THE MOST POPULAR ECOMMERCE PLATFORM IN THE WORLD?
Screw you godaddy.
dknzdesign replied on at Permalink Reply
Yeah this piece of code slapped to the end of my .htaccess file worked
Thanks bro.

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^(default.htm)/?$ index.php
RewriteRule ^(default.html)/?$ index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$http://%{HTTP_HOST}/index.php/$1... [L]
</IfModule>
EvolutionPilates replied on at Permalink Reply
thank you for posting this - we'll be trying this tonight.
JustinSI replied on at Permalink Reply
I'm also having this problem and have tried adding this code to the end of my htaccess file that worked before GoDaddy upgraded Apache. I still don't get the short URL's to show the pages.

Did you also change the cgi settings that was recommended above or just add this to the end of your htaccess?

Thanks!
EvolutionPilates replied on at Permalink Reply
We tried everything -- and we've decided to switch hosts. GoDaddy has been, to say the least, VERY unhelpful.
pgee replied on at Permalink Reply
Did anyone every get a solution to this problem?
5.5.2.1 ( I think php version is 5.2.14)

I too am at wits end...Godaddy upgraded my server from apache 2.2 to 2.4 ( no notice , no communication whatsoever..!!!)

Several sites hosted on godaddy (I can't even write that name now without feeling angry).

My concrete5 site has a front page only - errors when trying to go to sub pages including the login admin page.

I tried all sorts of changes suggested to .htacess files and can't login to change pretty urls (how do I turn off at server level?)

thanks ..really thanks!
Katasdf replied on at Permalink Reply
Hey Pgee,

I actually ran into the same problem when checking one of my sites today. Thankfully anedix's fix seems to have worked for me as of today, which is the code below:

# -- concrete5 urls start --
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^(default.htm)/?$ index.php
RewriteRule ^(default.html)/?$ index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ http://%{HTTP_HOST}/index.php/$1 [L]
</IfModule>


I've also read that having a file named php5.ini in the root folder helps fix the issue. The two in conjunction worked for me!

The contents of my php5.ini file are below:
cgi.fix_pathinfo = 1


Thanks anedix for the fix!
pgee replied on at Permalink Reply
Hi Katasdf,

Can I just check with you. do you have pretty urls turned on?
I can make a change to the htaccess file and get teh pages working BUT with pretty urls off and all links with index.php straight after my site name...so all web links to my site will be broken...clearly not a great workaround.

But I cannot get the pretty urls to work again

Phil
pgee replied on at Permalink Reply
Also I currently have

cgi.fix_pathinfo = 1
cgi.force_redirect = 0

in my php5.ini file two levels up from my concrete folder - the html folder
pgee replied on at Permalink Reply
I have now put php5.ini in the directory above as well.
The other forum recom htaccess Im using that gets me to a page not found error on c5 is as follows. ( the one above gets me to another error outside of c5 ).



<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
</IfModule>



errros in c5 are

Page Not Found
No page could be found at this address.
Back to Home.

Page Forbidden
You are not authorized to access this page.
Back to Home.

Please can you confirm the permissions of

php5.ini
site.php
.htccess files thanks so much

Phil
bcarone replied on at Permalink Reply
bcarone
Another thing to check is in your .htaccess file. Ensure your zend version is the current one that GoDaddy has installed. Find your version in your phpinfo.PHP file
pgee replied on at Permalink Reply
Hi bcarone, thanks for the info.

Please can you tell me where phpinfo.php and resides - it's location
thanks
pgee replied on at Permalink Reply
also what to check in the htaccess file - you didnt say..??
thanks
jasonkf1 replied on at Permalink Reply
jasonkf1
Was everything resolved by switching from godaddy to another hosting company?
shondy replied on at Permalink Reply
shondy
Having the same issue with this site - toursaintlaurent.com

Got a call from an irate site owner who is paying for advertising to promote a website with no pages. Not good.

I had to disable pretty URLs, clear caches, etc. to get back to some kind of normal. But this is obviously not the ideal condition to leave things in.

I tried all of the fixes listed but they are on Godaddy shared hosting, so I will be putting in a support ticket with them. Is there any time frame on when this started becoming a problem?

What would be the process for creating redirect rules if I have to leave the pretty URLs off for a while? I would want all the external links that reference the pretty URLs to redirect to the non-pretty ones.

Hopefully someone will come up with a solid solution. I am just concerned that there a lots of unmonitored sites out there and people have no idea that they are not working!
jasonkf1 replied on at Permalink Reply
jasonkf1
Hey, I just visited the site you mentioned. Did you turn off Pretty Urls? Looks like it to me.. I am having the same issue now with 2 sites I build both worked 100% fine then all of a sudden calls about "My pages aren't working" descriptive as that is I went to investigate the issue.

I checked everything I could think of, cleared all cache, turned cache off, modified .htaccess file to older versions, custom edits etc. all to no avail. I don't need to rewrite the index.php in the url, I just turn off pretty urls for that...

With Pretty Urls off the site can be navigated which is alright, but anything indexed or linked to the page from another source is sure to be jacked up. So the pretty urls are pretty important for that reason. This makes it very important to have pretty urls enabled and functioning correctly.

I'm 100% convinced that this is due to a change on GoDaddy's share environments. They must have made changes in the way the rewrite rules are being implemented.

A client that reported this issue to me said they spent 45 minutes on the phone with GoDaddy and their support said "Your developer coded something wrong in the index.php file." I haven't touched the index.php at all.

How is it possible I'm hearing the same issue I am faced with all concrete5 sites, all godaddy hosting, all the same bs. It seems that this is no coincidence. I know GoDaddy rolled out some updates to their interface for various control panel stuff such as file manager. I imagine a number of other things could have changed as well so I still think that this issue is on GoDaddy.

Anyone else having this issue? Anyone else have a resolution? If I get one this evening I hope it is GoDaddy fixing their issue so we all(whom are having this issue) are able to enjoy our weekends..
shondy replied on at Permalink Reply
shondy
I just the most lame response from Godaddy support. It's like they didn't even read the response I sent them. From what I am gathering they are saying that it has to with FastCGI and Apache, although Godaddy claims that they have been using FastCGI on shared hosting for some time due to performance improvements. But yes, something clearly changed. They say that you have to have VPS to make changes to the PHP environment, so it looks like everyone is SOL, unless someone discovers a fix that they (nor Godaddy obviously) are aware of and willing to share.

I did also see stuff about Zend- not sure how to handle that.
pacanas replied on at Permalink Reply 1 Attachment
ertyh
leestrayer replied on at Permalink Reply
I don't know if anybody found this fix yet. Apache 2.4 has screwed up the old rewrite rules.

This is the file that works now...

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^(default.htm)/?$ index.php
RewriteRule ^(default.html)/?$ index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$http://%{HTTP_HOST}/index.php/$1... [L]
</IfModule>

I'm at Godaddy, too, and they gave me this fix. Hope it helps
leestrayer replied on at Permalink Reply
I don't know if anybody found this fix yet. Apache 2.4 has screwed up the old rewrite rules.

This is the file that works now...

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^(default.htm)/?$ index.php
RewriteRule ^(default.html)/?$ index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ http://%{HTTP_HOST}/index.php/$1 [L]
</IfModule>

I'm at Godaddy, too, and they gave me this fix. Hope it helps
leestrayer replied on at Permalink Reply
I don't know if anybody found this fix yet. Apache 2.4 has screwed up the old rewrite rules.

This is the file that works now...

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^(default.htm)/?$ index.php
RewriteRule ^(default.html)/?$ index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ http://%{HTTP_HOST}/index.php/$1 [L]
</IfModule>


I'm at Godaddy, too, and they gave me this fix. Hope it helps
bubbahotep replied on at Permalink Reply
Anyone found a way on GoDaddy to recover fully pretty URLs? Cuz the solutions above seem to enable requests via the pages for a pretty URL, but they end up printing in the location bar as ugly again.

Hmmm, I just recently jumped through these hoops at GoDaddy as well but the guy I talked to didn't actually fix my issue. (I was actually trying to setup Concrete5 on a subdirectory and attached to a forwarded URL so I have twice the headaches)...

I have another site that's using Concrete5 just for grins and it's the only domain on the hosting plan and there's no fancy forwarding or anything, just the one domain, one website. I tried entering your lines into my htaccess file and the solution worked, but only sorta.

I can enter pretty URLs into the location bar, but then they're translated into uglier ones. (from mysite.com/category/product/ to mysite.com/index.php/cateogory/product.

So while I can appreciate that it helps sites not be down, has anyone found a way to recover the way pretty urls?
leestrayer replied on at Permalink Reply
Sorry about the repeat posts. The site keeps hanging when I post.

The fix I posted does work, but as bubbahotep noted, the ugly urls post back to the browser even after calling the page with the pretty url. So the fixed .htaccess gets things running again, but not all of the way.

If anybody can post a fix that sends back the pretty url, we'd all be thankful.
jasonkf1 replied on at Permalink Reply
jasonkf1
Still looking for the answer... Spoke with GoDaddy for a while on the phone and found out the following. Within the last 3 weeks they rolled out upgrades to apache now using apache2.4 and they also are only supporting php5.2X/FastCGI. So they are only using the fastcgi wrapper apis.

Has anyone tested concrete5 on a server with apache2.4 and php5 fastcgi outside of godaddy and had the same results? Or is this specific to godaddy and their shared environments?

I will tinker on this a little more this evening and will post back again. Best of luck to all battling the same issue. Oh also, regarding this issue, godaddy basically said tough $|-|!t figure it out yourself..

--EDIT

Anyone also using the APC optimization instead of Zend on their problem site with GoDaddy?
shondy replied on at Permalink Reply
shondy
I got this to work, and hopefully it will work for everyone else.

1. Disable pretty URLs.
2. Clear the cache. Even turn off caching until you find our that it is working.
3. Make sure that the block of code that Concrete5 injects into the .htaccess file is not present. starts with "# -- concrete5 urls start --" and ends with "# -- concrete5 urls end --". Remove those lines too, as they will be re-injected when you enable Pretty URLs again.
4. Add this line to the site.php file found in the root config folder. If it is not present on your local machine download it.
define('SERVER_PATH_VARIABLE', 'REQUEST_URI');

5. Add this code to the top of your .htaccess file
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^(_app) - [F,L]
RewriteRule ^(_config) - [F,L]
RewriteRule ^(_content) - [F,L]
RewriteRule ^(.*).yml$ - [F,L]
RewriteRule ^(.*).yaml$ - [F,L]
RewriteRule ^(.*).html$ - [F,L]
RewriteRule ^(.*/)?\.git+ - [F,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /index.php [QSA,L]
</IfModule>
#Disable FastCGI

6. Enable Pretty URLs again.
7. Check to make sure Concrete5 injected the code into the .htaccess file as so:
# -- concrete5 urls start --
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
</IfModule>
# -- concrete5 urls end --

I have also seen this version of the rewrite rule
RewriteRule ^(.*)$ http://%{HTTP_HOST}/index.php/$1 [L]

and tested it, and it appears to work with either version.

8. Have the file php5.ini in the root of your installation with only the following lines of code present:
cgi.fix_pathinfo = 1
cgi.force_redirect = 0

9. Remove the file php.ini if it is present in the root of the Concrete5 installation.

I hoped this helps someone- I was thinking that I wasn't going to get it fixed, or was going to have to move to another host. Dodged a bullet there.
jasonkf1 replied on at Permalink Reply
jasonkf1
First of all thank you..

Ok, I can confirm that the above has worked as well. The version of Concrete5 confirmed on is: v5.6.1.2

(for those getting here with installation issues)
So by default GoDaddy uses APC optimization instead of Zend. We need to address this in 3 possible locations. The php.ini, php5.ini and the /config/site.php depending on your preferred optimization.

So here is the complete solution as outlined above peppered with my own experience of the issue and the complete code blocks/locations that should get you going again on godaddy, again thanks goes to cschondel.

Above mentions deleting the php.ini file however I do not believe that is necessary.

Settings for running Concrete5(v5.6.1.2) on GoDaddy(Apache2.4 PHP/FastCGI Api)

php.ini (using apc)
register_globals = off
allow_url_fopen = off
expose_php = Off
max_input_time = 60
variables_order = "EGPCS"
extension_dir = ./
upload_tmp_dir = /tmp
precision = 12
SMTP = relay-hosting.secureserver.net
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="
;Not using..
; Only uncomment zend optimizer lines if your application requires Zend Optimizer support
;[Zend]
;zend_optimizer.optimization_level=15
;zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.3


php5.ini
cgi.fix_pathinfo=1
cgi.force_redirect = 0
session.save_path = "/tmp/"
;APC
extension="apc.so"
apc.enabled=1
apc.shm_segments=1
apc.shm_size=128
apc.ttl=7200
apc.user_ttl=7200
apc.num_files_hint=1024
apc.enable_cli=1


If you are using Zend instead then use the following in your php5.ini
apc.enabled=0


/config/site.php
<?php 
define('DB_SERVER', '...');
define('DB_USERNAME', '...');
define('DB_PASSWORD', '...');
define('DB_DATABASE', '...');
define('PASSWORD_SALT', '...');
define('CACHE_LIBRARY', 'apc');
define('SERVER_PATH_VARIABLE', 'REQUEST_URI');
?>


.htaccess (With Pretty URLs = true)
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^(_app) - [F,L]
RewriteRule ^(_config) - [F,L]
RewriteRule ^(_content) - [F,L]
RewriteRule ^(.*).yml$ - [F,L]
RewriteRule ^(.*).yaml$ - [F,L]
RewriteRule ^(.*).html$ - [F,L]
RewriteRule ^(.*/)?\.git+ - [F,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /index.php [QSA,L]
</IfModule>
# Disable FastCGI


Please allow ~20 min for changes in your *.ini files on the shared environments. If they aren't immediate do not panic. This can make successive testing through trial and error painful so..
james13009 replied on at Permalink Reply
Thanks Jason!

This is the furthest I have got so far, however one problem I am having is the disappearance of my edit bar.

I am copying a .co.uk site to an .es site (now on godaddy), so nothing should have changed.

The domain is:
http://www.addfieldincineradoras.es...

-Can't see any javscript errors
- The dashboard is accessible e when i type the url - I just can't edit pages
-This is present is the footer.php
<?php Loader::element('footer_required'); ?>
</body>

What could it be?
FischerVision replied on at Permalink Reply
FischerVision
Jason, change your site.php code from

define('SERVER_PATH_VARIABLE', 'REQUEST_URI');

to
define('SERVER_PATH_VARIABLE', 'REQUEST_URL');
jasonkf1 replied on at Permalink Reply
jasonkf1
There is a difference, it isn't a mistake. Just want to be sure not to misplace your querystrings.

$_SERVER['REQUEST_URI'] and $_SERVER['REQUEST_URL']
URI provides the entire request path (/directory/file.ext?query=string)
URL provides the request path, without the query string (/directory/file.ext)


Best regards,
Jason
nogardtla replied on at Permalink Reply
Thank you very much. Been fighting with this all day trying to get it working. Followed the steps exactly and everything is working well now.
justrj replied on at Permalink Reply
justrj
This worked for me - GoDaddy Hosting
TeleFox replied on at Permalink Reply
Tried everything.Cant understand what the problem is!
LordByron replied on at Permalink Reply
LordByron
I've had an open ticket with GoDaddy since July 25th, supposedly the engineers are trying to replicate the problem and find a solution. But I haven't heard anything back from them.

For me, I can't even run a new install of c5. My c5 sites are setup in a folder at my site root named /concrete_sites/ and every-time c5 makes a request to the server to find out where it is located (pages, css, js, images, etc...) the server is returning the path from the root of my hosting account, not the web relative path. (Two weeks ago it returned the web relative path, and everything worked fine.)

The low level GoDaddy tech sore that they didn't change anything, but obviously they did, I'm not sure if this is the result of a security update they ran, or they are just trying to make their "unlimited" plans so you can only run one site on each.

The "fixes" listed in this thread haven't helped my case any as since it is the php function that is returning the wrong address and writing the links to the html, the .htaccess fixes don't process (could make the links okay, but css and images are still broke). And since the error occurs at c5 install, there isn't yet a site.php to edit.

Also GoDaddy says that FastCGI is turned off, but phpinfo() reports otherwise, but they insist that FastCGI couldn't cause the wrong address being returned (I think I'd agree with them) that it just causes loop-like problems.
GoDaddyLuis replied on at Permalink Reply
I wanted to chime in and start by saying I'm truly sorry for any inconvenience or frustration this may be causing, we understand how important optimal performance is to our customers and their respective sites.
Our Hosting admins are fully aware of this situation. We have gathered all of the details as well as feedback and will be releasing a help article soon on our Community page answering some of these questions and walking customers through the process. Thank you.

Respectfully,

Luis
Go Daddy Social Media Team
NetFronts replied on at Permalink Reply
[code][/code].
NetFronts replied on at Permalink Reply
well, Our websitehttp://www.netfronts.ca is suddenly down now which is really bad since we are starting a new business .I thought godaddy was the best am starting to change my mind and review my options .
joelle253 replied on at Permalink Reply
Moving from GoDaddy to a different host may not help. I use Green Geeks for my host, and had a similar problem when Green Geeks upgraded Apache to 2.4 a few days ago. I came across this Concrete5 screen while searching for a solution to my problems.

When Green Geeks did its Apache upgrade, no notification was sent to me. My Website crashed in the middle of the night, and stayed down for many hours. When it was finally restored to service, Green Geeks staff insisted I had done something to cause the problem! They blamed me for several days before finally admitting there had been an Apache upgrade which caused the crash.

To make matters worse, they changed my htaccess file without notifying me, and they completely removed my php.ini file (also without notifying me). I am now being told that Green Geek customers on shared drives are no longer allowed to have their own php.ini file. So for those of you who think GoDaddy is bad, things can be worse.
exchangecore replied on at Permalink Reply
exchangecore
For what it's worth we run Apache 2.4.9 and several C5 sites, no complaints or problems thus far.
felixb101 replied on at Permalink Reply
felixb101
Same here, it works fine. The .htaccess, php.ini, php5.ini and the config.php are required though. We usually run the sites with caching off.