SOLVED: "No input file specified" problem on SiteGround

Permalink 2 users found helpful
Here is some info that might be helpful to others (this was for the host "SiteGround", but may apply to other shared hosts that have the same problem).

When I turned on Pretty URL's on SiteGround shared hosting, I kept getting "No input file specified" errors. The way I solved this was by setting this...

cgi.fix_pathinfo = 0

...in the php.ini file (seehttp://www.concrete5.org/index.php?cID=5346... for more details).

SiteGround doesn't allow you to modify the default php.ini file, so just create your own and put it in the root directory of your concrete5 installation, and it will pick it up. Note that you only need to put this one line in the new php.ini file -- it will be added to all of the other settings from the default php.ini file.

jordanlev
View Replies:
wizard247 replied on at Permalink Reply
wizard247
Thanks, I'm also with SiteGround and have added the php.ini file to my root.

Also changed the .htaccess file to:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>


As recommended - and got rid of the "input file not specified" message, however, now each page goes to my index page, no matter if I type in the pretty URL, all pages go to index page.

Any ideas?
Thanks,
Wizard247
jordanlev replied on at Permalink Reply
jordanlev
The 2nd-to-last line of your .htaccess file should be this:
RewriteRule ^(.*)$ index.php/$1 [L]


(so replace the existing line "RewriteRule . /index.php [L]" with that one)
wizard247 replied on at Permalink Reply
wizard247
OK - works now. Thanks
dghalsema replied on at Permalink Reply
dghalsema
Still the right solution in February 2012. Thank you!
Responsive replied on at Permalink Reply
Responsive
Hi Jordan

I just moved to siteground and uploaded vers 5.6.2.1 , created the php.ini in the root directory of the installation with just the one line cgi.fix_pathinfo = 0 , now I dont see the toolbar.

Not sure if I have missed something, can you please advise if you had same problem.

thanks