Strict Standards again...


I was a happy concrete5-User so far, but the "Strict-Standard-error" occured at my page
the last days:

Strict Standards: Non-static method Cache::get() should not be called statically in /home/www/xx/ on line 78
Strict Standards: Non-static method Cache::key() should not be called statically in /home/www/xx/ on line 111
Strict Standards: Non-static method Cache::getLibrary() should not be called statically in /home/www/xx/ on line 115

I already found some threads about this topic. All suggests refer to the error_reporting-variable. At my webserver, it is set to

which seems to correspond to E_ALL (I got the value 32767 via phpinfo()). The problem is, that I don't have the permissions to edit the php.ini of my webserver.

Is there any possibility to solve this problem?

What's really strange about it: The site ran without any problems for months! My provider said, that he didn't change any php-configurations.

Thanks for any hints!

Greetings from Germany,

View Replies:
noXstyle replied on at Permalink Reply
Are you running your site on development mode? (See sitewide settings/debug). Running on production should turn off the error reporting...

Also if that doesn't help you can use PHP's ini_set to set the reporting level:
ini_set('display_errors', '0');
dawu replied on at Permalink Reply
Thanks for your fast answer! Very nice!

As far as I know, I didn't change to development mode. Unfortunately I am not able to log in anymore. After entering the username an pw, I only get Strict standard errors.

I forgot to mention that display_errors is already set 'off', as I can see at phpinfo().
dawu replied on at Permalink Reply

the problem is solved. My server provider found the problems. Some technical issues at the server.