Strict Standards

Permalink
I have concrete5 installed in two places. One is on my server with 1and1, and the other is on my desktop with XAMPP. Both places I'm getting these errors:

Strict Standards: Non-static method Loader::helper() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\5\concrete\libraries\controller.php on line 47

Strict Standards: Non-static method Object::camelcase() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\5\concrete\libraries\loader.php on line 221

Strict Standards: Non-static method Loader::helper() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\5\concrete\libraries\controller.php on line 47

Strict Standards: Non-static method Object::camelcase() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\5\concrete\libraries\loader.php on line 221

Strict Standards: Non-static method Loader::helper() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\5\concrete\controllers\install.php on line 136

Strict Standards: Non-static method Object::camelcase() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\5\concrete\libraries\loader.php on line 221

Strict Standards: Non-static method Loader::helper() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\5\concrete\themes\core\concrete.php on line 13


I've tried what I could find in the forums here with the edits to my php.ini file, and they are not working.

I'm trying to set up the same version that we have installed on our production server 5.4.1 (I know it's old, we are going to update)

any ideas?

View Replies:
JohntheFish replied on at Permalink Reply
JohntheFish
I think that standards report glitch has been fixed.

You should be able to turn off / disable reporting on strict standards in the php ini file for your localhost (maybe that is what you have already tried).

On a 1&1 shared host, the chances are any such entries you make within your site ini file will be filtered out and ignored by 1&1s security, so you will have to look for a setting in the 1&1 control panel. Their tech support can probably point you in the right place. It may be a case of switching to an older php version where the default for strict standards is the other way round.
aleech replied on at Permalink Reply
I'm currently using a self hosted set up. I've tried multiple options.

WAMP is the only one that has even come close to letting me set up a Concrete5 site.

I have turned off and disabled strict standards using every method that I have found in the forums, and yet it still keeps showing up.