Stuck in Maintenance mode

Permalink 1 user found helpful
Please HELP!!! I entered "maintenance Mode" and did an update. The site found the new 5.5.2.1 version for update. It was downloaded smoothly and i followed the update prompt. Again it went smoothly and notified me that update was complete. I then choose to go back to site and it shows the site is in maintenance mode. Seeing this i think "no big deal" so i just re log in as the admin.....NOPE, to my surprise when i log in as admin i get the same "site in maintenance mode" and no dashboard to get it out of maintenance mode. Any one else having this problem? This is quite frustrating since i do not have access to the server files.

Don

View Replies:
PauloCarvalhoDesign replied on at Permalink Reply
PauloCarvalhoDesign
Try this assuming your admin or else change the admin for your username:

<?php
defined('C5_EXECUTE') or die(_("Access Denied."));
Loader::model('user');
if ((!$c->isAdminArea()) && ($c->getCollectionPath() != '/login')) {
$smm = Config::get('SITE_MAINTENANCE_MODE');
$u = new User();
if ($smm == 1 && $u->getUserName() != "admin") {
$v = View::getInstance();
$v->render('/maintenance_mode/');
exit;
}
}
vytautas replied on at Permalink Reply
thank you Paul but i have no access to the server, our site is piggybacked on someone else's site. This really sucks
emsconcrete replied on at Permalink Reply
emsconcrete
Hi Paulo,

In what file would you put this code?

Thanks,
George
PauloCarvalhoDesign replied on at Permalink Reply
PauloCarvalhoDesign
Sorry misread this last line.
vytautas replied on at Permalink Reply
Are there any other options?
PauloCarvalhoDesign replied on at Permalink Reply
PauloCarvalhoDesign
vytautas replied on at Permalink Reply
Both options return "page not found"
vytautas replied on at Permalink Reply
Ok Paul, i finally got it to work, you are a savior. TY for the help. Its ppl like you that make this program work.

Don
PauloCarvalhoDesign replied on at Permalink Reply
PauloCarvalhoDesign
Would be great if you mark this as best awnser!
dreesor replied on at Permalink Reply
dreesor
totally best answer. thanks for your help.
lgallp replied on at Permalink Reply
lgallp
Thanks a lot for the help on this publication. I just had the same problem and solved it with this.
JB2U replied on at Permalink Reply
OK ... what was the 'best answer' I can't see that there was one. The yoursite links are now dud, and Paul didn't say what file his code should be put in? Anyway is this relevant to v5.7 ?
JohntheFish replied on at Permalink Reply
JohntheFish
In 5.7, logged in as the super admin, you should still be able to go directly to the dashboard and the MM page as suggested above.

The MM flag is still a flag in the database, so if not logged in you can also go to the Config table in phpMyAdmin and change it.