superuser Access Denied and other strangeness

Permalink 2 users found helpful
So after an ordeal with my php.ini file, which the kind folks at Dot5hosting solved for me, I still have the following issues:

Superuser (admin) gets a funny little popup window stating Access Denied when trying to view the sitemap tab in the back-end.

Superuser also cannot edit which groups a user belongs to (including self)

When "Return to Website" is clicked, the bar indicating login status and granting option of editing pages ... disappears.

There are no errors reported in the logs.
Clearing the cache (site AND browser) had no affect.
Deleting the browser cookie had no affect.
I've read about Advanced Permissions but can't find where to turn them on/off so unless they're on by default, they are off.

I'm completely stumped.

UPDATE: noticed that the # of admin logins increments by four simply by clicking to a different back-end tab and then immediately back to the Users and Groups tab. Tried altering the session.save_path var in php.ini to no affect.

ParaplegicRacehorse
View Replies:
hauke replied on at Permalink Reply
hauke
I currently do have the same problems! I can't login without using the "remember me"-option. After login, I can't access the sitemap with the same error saying: No permission. May there be a problem with the php-sessions? So far, I dind't find a solution for this.
Is there any way to restore the initial permissions?
brennaH replied on at Permalink Reply
brennaH
I am now having the same issue with one of my client sites. I've completely ripped out and re-installed the application, removing any customizations. Same result.

My instinct tells me it's config problem on the server -- maybe something with .htacess or folder permissions? The install is on a host that I have never worked with before so perhaps it's in the default php.ini?

Has anyone discovered a solution to this? Any leads? I'm a bit stumped at this point.
fridayphoto replied on at Permalink Reply
fridayphoto
Hi there, I'm having this same weird problem with a certain host. C5 works fine for me on numerous other occaisions but on this new install I'm getting the above described symptoms. I have noticed that the 'admin' user isn't a apart of the 'Admininistrators' group. Can't add the group either, 'access denied'.

Is there a simple way to add the group to the user manually in the mySQL?
Mnkras replied on at Permalink Reply
Mnkras
The super user doesn't need to be in the Administrators group, it has root access, try re-uploading the /concrete directory
justrj replied on at Permalink Reply
justrj
I am experiencing the same problem. If I don't click "remember me," I can't log into c5 in the 1st place and now I have access denied anytime I attempt to edit the site.

Has anyone tried a clean install to server?
mkly replied on at Permalink Reply
mkly
By "Access Denied" do you mean that you just see black text at the top or does it have to Concrete5 banner on top?
justrj replied on at Permalink Reply
justrj
I mean I can log in, but whenever I went to "do" something such as add a new page, or even edit and existing page under my superuser, or any other user there would be a message that says "Access Denied"

I don't know what everyone else tried, but I uninstalled concrete5 from the server and performed a manual installation as outlined here:
http://www.concrete5.org/documentation/installation/installing_conc...

I had already upgraded to advanced permissions so per my reading it seemed hopeless to try to do anything else, but if there was some other fix I would definitely like to know for my reference.
mkly replied on at Permalink Reply
mkly
EDIT: Oh I think I understand.
justrj replied on at Permalink Reply
justrj
Thanks - just to clarify - it depended on where I was in the system.

For example: in the dashboard "Access Denied" would show up just below the top level page while I'm trying to add a page.

in page edit mode if I'm attempting to view the design, or permissions, etc. it would appear directly in the drop down

and the whole page if I tried to navigate to a sub-level page.
glockops replied on at Permalink Reply
glockops
Just experienced this same problem after moving a 5.5.2.1 site to a new server. Does anyone have a fix?