Error during upgrade from 5.6.1.2 to 5.6.3.2

Permalink
When attempting to run the Upgrade from 5.6.1.2 to 5.6.3.2, I'm getting the following error - I tried to 'Rerun script' but it gives the same error.

An Unexpected Error occurred while upgrading: #0 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/libraries/3rdparty/adodb/adodb.inc.php(641): adodb_throw('mysqlt', 'DOQUOTE', -9999, 'Numeric field t...', '', false, Object(ADODB_mysqlt)) #1 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/core/libraries/model.php(44): ADOConnection->outp_throw('Numeric field t...', 'DOQUOTE') #2 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/libraries/3rdparty/adodb/adodb-active-record.inc.php(845): Concrete5_Library_Model->doquote(Object(ADODB_mysqlt), true, 'I') #3 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/core/models/block_types.php(763): ADODB_Active_Record->Replace() #4 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/core/models/block_types.php(671): Concrete5_Model_BlockType->doInstallBlockType('guestbook', Object(BlockType), '/WEBSITEADDRESS...', '10', '/WEBSITEADDRESS...') #5 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/core/models/block_types.php(632): Concrete5_Model_BlockType->installBlockType('guestbook', '10') #6 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/helpers/concrete/upgrade/version_563.php(17): Concrete5_Model_BlockType->refresh() #7 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/core/controllers/single_pages/upgrade.php(272): ConcreteUpgradeVersion563Helper->run() #8 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/core/controllers/single_pages/upgrade.php(44): Concrete5_Controller_Upgrade->do_upgrade() #9 [internal function]: Concrete5_Controller_Upgrade->view('tools', 'required', 'upgrade') #10 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/core/libraries/controller.php(267): call_user_func_array(Array, Array) #11 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/core/libraries/controller.php(237): Concrete5_Library_Controller->runTask('view', Array) #12 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/core/libraries/view.php(787): Concrete5_Library_Controller->setupAndRun() #13 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/tools/upgrade.php(6): Concrete5_Library_View->render('/upgrade') #14 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/startup/tools_upgrade_check.php(9): include('/WEBSITEADDRESS...') #15 /WEBSITEADDRESS/updates/concrete5.6.3.2/concrete/dispatcher.php(105): require('/WEBSITEADDRESS...') #16 /WEBSITEADDRESS/concrete/startup/updated_core_check.php(6): require('/WEBSITEADDRESS...') #17 /WEBSITEADDRESS/concrete/dispatcher.php(14): require('/WEBSITEADDRESS...') #18 /WEBSITEADDRESS/index.php(2): require('/WEBSITEADDRESS...') #19 {main}

View Replies: View Best Answer
hutman replied on at Permalink Best Answer Reply
hutman
Try upgrading from 5.6.1.2 to 5.6.3 then to 5.6.3.2, I ran into the same problem when I skipped the 5.6.3 upgrade.
sergeant replied on at Permalink Reply
Thanks for this, I'm using the automated upgrader, how do I run a manual upgrade?
hutman replied on at Permalink Reply
hutman
sergeant replied on at Permalink Reply
Interestingly, I now have three different C5 sites with exactly the same error on upgrade attempt, was there a fundamental issue with this release and it's upgrader?

Any ideas on how to actually fix it rather than just do a manual install?
Jessicasdd replied on at Permalink Reply
The link to the downloads page, from the Manually Upgrade Concrete5 page, does not work. It is supposed to go tohttp://www.concrete5.org/developers/downloads/... but gives a 404 - "This page was not found" error.

Is there another way to get this information?

Thanks,
Jessica
hutman replied on at Permalink Reply
hutman
Here is a link to the downloads pagehttp://www.concrete5.org/get-started... it is in the main Concrete5 navigation as well
Jessicasdd replied on at Permalink Reply
I was looking for the downloads page. That is the home page. That doesn't give older versions to be able to step through to bring it current.

The page I wanted was this one:
https://www.concrete5.org/developers/developer-downloads/...

It gives all the legacy versions. I found it just before you replied.
sergeant replied on at Permalink Reply
Can anyone advise how to resolve this or similar errors during a C5 upgrade? The sites are not heavily customised but I now have this or a similar error for 3 sites in total and I am apprehensive to upgrade each manually.

How does one go about troubleshooting these unhelpful errors?
AndyJ replied on at Permalink Reply
Have you been able to revert back to your previous working instance?

If so, can you try a stepped upgrade as suggested previously?

I've had this same error and got around it by upgrading first to 5.6.3.1 and then to 5.6.3.2.

It is a known bug - and there is a workaround if the stepped upgrade doesn't work.

Try the incremental upgrade first though.
sergeant replied on at Permalink Reply
Hi @Andy, the failure only seemed to 'take down' 1 of the 4 sites that I need to upgrade, the other 3 revealed the error but remained online fortunately.

I haven't yet tried the stepped upgrade approach as I would have liked to have solved this issue and upgraded as usual - could you point me to the work-around as it would make sense to try this before a manual upgrade attempt?
sergeant replied on at Permalink Reply
And just to check, by the 'stepped upgrade', do you mean downloading and manually placing the updated version into the 'updates' folder? If so, isn't this the same process as the automated procedure and therefore would also fail?
sergeant replied on at Permalink Reply
Also, in my Updates folder, I've still got the downloaded 5.6.3.2 folder, do I simply delete it? I've tried renaming it and it seems to prompt an error:

Fatal error: require(): Failed opening required '/home/www.WEBSITE.com/updates/concrete5.6.3.2/concrete/dispatcher.php' (include_path='.:/usr/local/lib/php:/usr/local/php5/lib/pear') in /home/www.WEBSITE.com/concrete/startup/updated_core_check.php on line 6
AndyJ replied on at Permalink Reply
hi,
by stepped upgrade I just mean select to upgrade to 5.6.3.1 instead of 5.6.3.2 using the standard upgrade interface.

No manual intervention or anything. The reason the error occurs is because a datatype in the database is different in 5.6.3.2 and going through the previous version should transition this.

But, it can very much depend on which version you are on now and what has happened as you have received error messages and things might be mismatched.

What versions are your websites on?

It might be worthwhile making a list along with the version they are running and attacking them one at a time.
sergeant replied on at Permalink Reply
I see - ok I have found that to remove the 'automatically downloaded/failed' update, I had to edit the site.php file, remove the reference to the updated one and instead set it back to the current version. Now I'm able to remove the automatically downloaded folder in the 'updates' folder.

I am uploading the step upgrade files now, I'll let you know how I get on - thanks again for the help/support here!
sergeant replied on at Permalink Reply
Ok, so current website version for this first website is concrete5.6.1.2 and if I go to the 'Upgrade Concrete5' page in the admin panel, it states:

- Currently Running 5.6.1.2
- Available Update
- Version: 5.6.3.2. Release Date: September 15, 2014

However, I have uploaded concrete5.6.3.1 into the /updates/ folder and yet it's not showing for upgrade? What's going wrong here?
sergeant replied on at Permalink Reply
Ah...I clicked 'Download' to prompt the download of concrete5.6.3.2 as well, after finishing the download it's now giving me the option for which version I'd like to upgrade!

I'll give it a try with the concrete5.6.3.1 first...
sergeant replied on at Permalink Reply
Ok, upgrade to concrete5.6.3.1 went successfully, as did to concrete5.6.3.2 :)

Thanks for your help, I'll try the same with my other sites!
drazentomic replied on at Permalink Reply
Hi sergant,

How did you get the options?
My installation just show me the last version available in any folder in /update, dispite versions 5.6.3 and 5.6.3.1 also available in the same folder