The config/, packages/ and files/ directories permission issue

Permalink 1 user found helpful
I am trying to install C5 ver. on a 000webhost server with Apache ver. 2.2.13 (Unix)
PHP version 5.2.*

I have already tried changing all of the permissions (of the directories) to 755 and 777, but nothing seemed to get rid of that red line beside "Web Server Access to Files and Configuration Directories"

I already have googled the problem, and none of the suggestions seemed to work...

Thank you in advance!

View Replies:
oneilldesign replied on at Permalink Reply
I have the same problem. In addition to the two folders specified in the README file (/config and /files), the installation requests that /packages have its permissions set to 755 as well.

With my particular web host, I actually need to use the extra security permission, meaning I'm setting the permissions to 2755. In any case, I'm told the /packages folder does not have appropriate permissions.
Mnkras replied on at Permalink Reply
are you both on the same host?

try setting them all to 777 for install then 755 after install
kguadmin replied on at Permalink Reply
I went on C5 community's irc channel and inquired Sponge about this.
He told me to install on the root folder (public_html folder for those with 000webhost)
I did so, and miraculously, everything worked just as it should.
I am guessing the problem was that installation file was looking for those folders in the root directory of the website?

If anyone has inputs on this, please feel free to reply.

Is it even possible to install c5 on a sub folder of a website?
Andres08 replied on at Permalink Reply
It helps me a lot too. Thank you. But now am I front of another problem. System says that it is unable to connect to database. I made database name and username with highest privilege but nothing is done.

Any idea.


Mnkras replied on at Permalink Reply
make sure the mysql server isn't blocking the connection