Turn off pretty URL's from database

Permalink
Which table and column is pretty URL's turn on at?

I read a post from 2010 saying its in table Config, but mine only has cfKey, timestamp, cfValue, uID, and pkgID.

Where is it, i want to manually change it to '0'

View Replies: View Best Answer
MichaelG replied on at Permalink Reply
MichaelG
so, what's wrong with the pretty urls page in system & settings? And why do you want to turn it off?
dduke replied on at Permalink Reply
I am making a test environment and exported the database. But the server is responding with 500 errors and showing blank screens so I think it might have something to do with the pretty URL's.

What table and column is it? Please!
Mnkras replied on at Permalink Reply
Mnkras
Its in the Config Table
dduke replied on at Permalink Reply
Did you see the columns in my Config table? Is it one of those?
AndyJ replied on at Permalink Best Answer Reply
one of the values for cfKey in that table should be something like URL_REWRITING - if you have pretty urls turned on this should show a 1 - change it to 0.
dduke replied on at Permalink Reply
Yes, there it is, its in the column cfKey in the Config table.

Thanks! BTW this did not solve my 500 error but good to know.
AndyJ replied on at Permalink Reply
didn't think it would cure those errors.

I'd check the environment of your new instance - 5.4 is very old now.

I'd remove the ,htaccess completely as that is a likely culprit for 500 errors.
It probably still won;t work but then you should check your php error log for clues.
dduke replied on at Permalink Reply
Oh okay, I thought the .htaccess was needed. But I will remove it and check the PHP logs.

Thanks,
AndyJ replied on at Permalink Reply
hello - this isn't held in the database any more in version 5.7.

Basically if you have changed the setting to allow pretty URLs it should have updated the file:

/application/config/generated_overrides/concrete.php

there should be a section in that file for SEO

'seo' => array(
'url_rewriting' => 1
)

edit this to 0.

This should turn url_rewiting off but it won't edit your .htaccess

you'll need to edit that and remove the section:

# -- concrete5 urls start --
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
</IfModule>
# -- concrete5 urls end --

After this has been done you are essentially back in the situation where Pretty URLs has not been turned on.

Give it a go but I doubt this is what your problem is as the 500 error is likely to be coming from somewhere else.
dduke replied on at Permalink Reply
I am using 5.4
AndyJ replied on at Permalink Reply
apologies - in that case ignore what I wrote :)
Kurtopsy replied on at Permalink Reply
Kurtopsy
I've been searching for this for awhile. Exactly what I needed, and it fixed my site. Thanks! :)
sandyotpl replied on at Permalink Reply
sandyotpl
Thank You
Its working for me.
chansolo replied on at Permalink Reply
chansolo
This has helped me a great deal, thanks!!
kstansbury replied on at Permalink Reply
kstansbury
I am trying to add an external url that will redirect a given page to an outside url. I am having trouble figuring this one out. Can any help with this issue?