Ubuntu Installation..This Might Help

Permalink
I just wanted to post my experience with installing Concrete5 on my Ubuntu computer.

I had, what seem to be, the three most common errors when installing Concrete5. I'll go through them and just show how I fixed them.

1. The install said I needed to chmod 775 htmldiff.py. So I did that using the terminal.

2. Like many of you it said I didn't have the correct version of the GD Library. After a tip from another post on here I went into the Synaptic Package Manager and did a search for php gd. Sure enough there was a package called php5-gd. I downloaded and installed it, checked for errors again, problem solved.

3. Now for those pesky file permissions. The 3 files that seem to give everybody grief are /config, /packages, and /files. Using the terminal, I navigated to those files in the concrete folder and used chmod 777 packages, chmod 777 config and chmod 777 files. That fixed that problem.

4. I also had to fiddle with the mysql database. I made one named concrete and added a user (not root) to it. Once I checked the errors again the problems were solved.

5. On the installation screen I typed in "localhost" for the server name and put in my username and password and it worked like a charm.

I hope that helps somebody!!

Good luck!

View Replies:
adriaanbotha replied on at Permalink Reply
Cannot get this right

Tried installing a concrete5 on apache on Ubuntu, can someone help ?

Thanks
minnie000 replied on at Permalink Reply
What errors is it giving you?
adriaanbotha replied on at Permalink Reply
Thanks Minnie, I managed to make it work.

I had a permissions problem on the files/ config/ packages/ directories

I found this link for alternative help
http://linuxconfig.org/installation-of-concrete5-cms-on-fedora-linu...

I do have an alternative problem now, but this is with cURL or my setup which is behind a firewall

thanks
smueller8746 replied on at Permalink Reply
Thanks a billion! This post helped a ton! :)