Unable to get permission key for view_newsflow

Permalink
After upgrading our website I have hit the following issue displaying an error while upgrading from '5.5.2.1' to '5.6.0' (have also tried to jump straight to '5.6.0.2' but no change)...

An unexpected error occurred.
Unable to get permission key for view_newsflow
< Back to Home


I have searched the forums HIGH and <em>low</em> bu have found nothing :'(

If anyone has had this issues or has a clue as to what is causing it, it may push me in the right direction in trying to solve this.

Thanks.

ChrisWatterston
View Replies:
mkly replied on at Permalink Reply
mkly
burbleweb replied on at Permalink Reply
Hi There

Just wondering I have read the linked bug article although I can't seem to reply to it - I can't quite work out where I am suppoed to add that code too though? I have the exact same issue having donwe and ugrade from 5.4 to 5.5. to 5.6

Thanks
dkchapuis replied on at Permalink Reply
Same problem when upgrading. Where do you apply the quick fix in the link?
chrisixion replied on at Permalink Reply
I had the same issue. I edited (my-site-root)/config/site.php and changed the version back to 5.5.2.1, i.e.:

define('DIRNAME_APP_UPDATED', 'concrete5.5.2.1');

This got my old site working again. I then backed up the database and tried the upgrade process again via the dashboard. Strangely enough it worked the 2nd time.

Strange, but I'll take it. Hope it helps someone.
TravelNet replied on at Permalink Reply
I've tried to update my site from 5.5.2.1 to 5.6.3.2 several times and keep receiving this error message:

An Unexpected Error occurred while upgrading: #0 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/libraries/3rdparty/adodb/adodb.inc.php(641): adodb_throw('mysqlt', 'DOQUOTE', -9999, 'Numeric field t...', '', false, Object(ADODB_mysqlt)) #1 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/core/libraries/model.php(44): ADOConnection->outp_throw('Numeric field t...', 'DOQUOTE') #2 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/libraries/3rdparty/adodb/adodb-active-record.inc.php(845): Concrete5_Library_Model->doquote(Object(ADODB_mysqlt), true, 'I') #3 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/core/models/block_types.php(763): ADODB_Active_Record->Replace() #4 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/core/models/block_types.php(671): Concrete5_Model_BlockType->doInstallBlockType('core_scrapbook_...', Object(BlockType), '/home/admin/dom...', '26', '/home/admin/dom...') #5 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/core/models/block_types.php(632): Concrete5_Model_BlockType->installBlockType('core_scrapbook_...', '26') #6 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/helpers/concrete/upgrade/version_560.php(102): Concrete5_Model_BlockType->refresh() #7 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/core/controllers/single_pages/upgrade.php(272): ConcreteUpgradeVersion560Helper->run() #8 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/core/controllers/single_pages/upgrade.php(44): Concrete5_Controller_Upgrade->do_upgrade() #9 [internal function]: Concrete5_Controller_Upgrade->view('tools', 'required', 'upgrade') #10 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/core/libraries/controller.php(267): call_user_func_array(Array, Array) #11 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/core/libraries/controller.php(237): Concrete5_Library_Controller->runTask('view', Array) #12 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/core/libraries/view.php(787): Concrete5_Library_Controller->setupAndRun() #13 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/tools/upgrade.php(6): Concrete5_Library_View->render('/upgrade') #14 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/startup/tools_upgrade_check.php(9): include('/home/admin/dom...') #15 /home/admin/domains/vemglobal.net/public_html/bluehr/updates/concrete5.6.3.2/concrete/dispatcher.php(105): require('/home/admin/dom...') #16 /home/admin/domains/vemglobal.net/public_html/bluehr/concrete/startup/updated_core_check.php(6): require('/home/admin/dom...') #17 /home/admin/domains/vemglobal.net/public_html/bluehr/concrete/dispatcher.php(14): require('/home/admin/dom...') #18 /home/admin/domains/vemglobal.net/public_html/bluehr/index.php(2): require('/home/admin/dom...') #19 {main}


Any advice on how to fix this. I tried looking for db.xml files, but I cannot locate them via FTP. I have no MySQL access. I've tried deleting 5.6 & downloading it again. This hasn't happened before when updating Concrete5.
Briann replied on at Permalink Reply
Looking at the error, the guestbook seems not related in your case.
But may be something similar is happening with another block?

http://www.concrete5.org/developers/bugs/5-6-3-2/upgrade-from-5.6.2...
TravelNet replied on at Permalink Reply
I resolved this issue by copying my update version of 5.6.3.1 from another test website to the new site. Then I installed 3.1 & 3.2 with no errors.
ecab54 replied on at Permalink Reply
Hi im a total newbie to C5 and I'm getting really frustrated. I tried the update, failed, added the code to the site.php file and came up with different errors this time.
The original errors are

An Unexpected Error occurred while upgrading: #0 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/libraries/3rdparty/adodb/adodb.inc.php(641): adodb_throw('mysqlt', 'DOQUOTE', -9999, 'Numeric field t...', '', false, Object(ADODB_mysqlt)) #1 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/core/libraries/model.php(44): ADOConnection->outp_throw('Numeric field t...', 'DOQUOTE') #2 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/libraries/3rdparty/adodb/adodb-active-record.inc.php(845): Concrete5_Library_Model->doquote(Object(ADODB_mysqlt), true, 'I') #3 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/core/models/block_types.php(763): ADODB_Active_Record->Replace() #4 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/core/models/block_types.php(671): Concrete5_Model_BlockType->doInstallBlockType('core_scrapbook_...', Object(BlockType), '/websites/lo/lo...', '1', '/websites/lo/lo...') #5 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/core/models/block_types.php(632): Concrete5_Model_BlockType->installBlockType('core_scrapbook_...', '1') #6 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/helpers/concrete/upgrade/version_560.php(102): Concrete5_Model_BlockType->refresh() #7 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/core/controllers/single_pages/upgrade.php(272): ConcreteUpgradeVersion560Helper->run() #8 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/core/controllers/single_pages/upgrade.php(44): Concrete5_Controller_Upgrade->do_upgrade() #9 [internal function]: Concrete5_Controller_Upgrade->view('tools', 'required', 'upgrade') #10 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/core/libraries/controller.php(267): call_user_func_array(Array, Array) #11 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/core/libraries/controller.php(237): Concrete5_Library_Controller->runTask('view', Array) #12 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/core/libraries/view.php(787): Concrete5_Library_Controller->setupAndRun() #13 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/tools/upgrade.php(6): Concrete5_Library_View->render('/upgrade') #14 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/startup/tools_upgrade_check.php(9): include('/websites/lo/lo...') #15 /websites/lo/logicalps.com.au/concrete5/updates/concrete5.6.3.2/concrete/dispatcher.php(105): require('/websites/lo/lo...') #16 /websites/lo/logicalps.com.au/concrete5/concrete/startup/updated_core_check.php(6): require('/websites/lo/lo...') #17 /websites/lo/logicalps.com.au/concrete5/concrete/dispatcher.php(20): require('/websites/lo/lo...') #18 /websites/lo/logicalps.com.au/concrete5/index.php(2): require('/websites/lo/lo...') #19 {main}

Can anyone please tell me why this is happening
PixelFields replied on at Permalink Reply
PixelFields
Also had the same issue; tried chrisixion's fix and no idea why but it seems to have worked. I was still getting the error even after the 'Update Concrete5' ran successfully to 5.6.3.2, but when I tested it in another browser it was fine. It's working again with all my client accounts - they can edit as well. I had already tried the guestbook fix with no luck previously.