Unable to install database error on fresh install

Permalink
So I am starting a fresh install, I have done everything needed including creating an empty database for concrete5 to install to.

But when I start the actual installation I get stuck on this error:
"Unable to install database: The table 'PermissionAssignments' is full"

So when I check the database there is 1 table that was created, "PermissionAssignments" so I try drop this table, and start the installation again but all that happens is the same thing.

View Replies:
ASCIIcat replied on at Permalink Reply
Well it seems I have solved this by changing the collation of my database from utf8_general_ci to latin1_sweden_ci I have no idea how this helped, but hey it's late and it worked
exchangecore replied on at Permalink Reply
exchangecore
That's slightly concerning to me. According to the MySQL documentation on this error (found here http://dev.mysql.com/doc/refman/5.5/en/full-table.html)... This error message happens when you don't have enough disk space available or a less likely case would have to do with mysql clustering which I doubt is your issue.

Changing the collation from utf8 to latin1 probably caused the size of the table to actually shrink, this is because latin1 uses single-byte encoding, therefore it can store more characters in the same amount of storage space because the length of string data types in MySql is dependent on the encoding.

I suspect that you should look into your available disk space / quotas / other things mentioned in the link i posted, I highly doubt that your issue stays away for long.
marcomeswara replied on at Permalink Reply
I think the intsall documentation should state clearly that an empty database has to be created first in order for concrete5 installation to proceed.