Upload_max_filesize issue

Permalink
I am getting the error below... could someone walk me through how to get past this. I need to be able to upload video files that are going to be lots larger. I am not familiar (already tried to figure this out) where the php.ini is or how to access the Htaccess file. I am hosted on dreamhost.com

I am comfortable changing/editing those if I could locate them. But by logging in via wsftp or looking in the admin panel couldn't find anything for doing it.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - -
An unknown error occurred while uploading the file. Please check that file uploads are enabled, and that your file does not exceed the size of the post_max_size or upload_max_filesize variables.

File Uploads: 1
Max Upload File Size: 7M
Post Max Size: 8M

View Replies:
Brainakazariua replied on at Permalink Reply
Brainakazariua
It might be that you can't edit the php.ini, in that case you can use the .htaccess which you can find in the root of your site, it should be there when you have pretty urls enabled and is accesible by FTP.

for the php.ini changes you can also try contacting your host and asking them to do it for you.
tonyboutwell replied on at Permalink Reply
They had a 1-click install and it didn't have that enabled by default. I contacted them about the php.ini and they sent me here and said good luck:

http://wiki.dreamhost.com/PHP.ini...

And that is just a wee bit over my comfort level to attempt. I am used to working in dreamweaver/html and doing site maintenance via ftp... but I have not worked with php or anything requiring a "shell" environment so I really would not know where to start to even attempt what it showing there.

:(
Brainakazariua replied on at Permalink Reply
Brainakazariua
Seems they love to take your money as long as they don't have to do a thing.
To make changes like that you need some basic unix skills.

I suggest you find someone who can help you with that in your direct enviroment since they'll need access to it with your username an password.
TheRealSean replied on at Permalink Reply
TheRealSean
You could try adding this to your top of your index.php
ini_set('memory_limit','128M');//this should do
ini_set('post_max_size','64M');//maybe this too 
ini_set('upload_max_filesize', '32M');//may not need this
set_time_limit(60);//only needed if you are processing large amounts of large files

I am not sure is if its the post_max_size or upload_max_filesize but one of them should do it.

If this works then you can overide the default php.ini settings I am not to sure the correct location to add them, index.php is not the best long term solution but easiest to test.

Ill see if I can remember/find the location for the file manager upload section.
curtis07 replied on at Permalink Reply
curtis07
jfhencken replied on at Permalink Reply
jfhencken
You can go to
Dashboard » System & Settings » Environment Information
and check the values for:

post_max_size - 10M
upload_max_filesize - 10M

I have a site on JustHost.com (BlueHost.com) which runs PHP v5.4.19

First I placed the following lines in a php5.ini file and placed it in /public_html and that had no effect.

file_uploads = On
upload_max_filesize = 100M
post_max_size = 100M
upload_tmp_dir = /tmp/


Next I changed the file name from php5.ini to php.ini and everything worked fine. A recheck of the Environment Info then read:

post_max_size – 100M
upload_max_filesize - 100M