Uploading databse phpmyadmin max size

Permalink
I am trying to upload a databse in phpmyadmin and when I do it tells me the database is too big (Max: 8,192KiB).

The problem is that I have allocated extra in my php.ini (1oo mb in both post and upload) file and when I view phpinfo.php it tells me the changes are correct but when I come back to phpmyadmin it tells me its is still (Max: 8,192KiB).

View Replies:
mhawke replied on at Permalink Reply
mhawke
Your host may be limiting the size of uploads. I would send then a quick tech support request.
auscoal replied on at Permalink Reply
Hi its my server
JohntheFish replied on at Permalink Reply
JohntheFish
phpMyAdmin is usually set up with a choice of sources for imports, as a file through a web form upload (where you are running into limits) and with a known directory/folder that you can ftp to and phpMyAdmin will then give you an option of importing directly from. The second option is usually needed for larger files.

You may be able to adjust both the upload limit and the location of the folder in phpMyAdmin's setup php file. That is the phpMyAdmin equivalent of c5's config/site.php, off the top of my head I don't know what it is called.

If you cant do any of the above, an SQL import file can always be chopped up into smaller files using a text editor and imported one part at a time.
jero replied on at Permalink Reply
jero
Assuming the passthru function is enabled (it might not be - depends on your server config), you could try uploading your dump.sql by FTP, and the uploading a php file like this:

<?php
define('DB_SERVER', 'localhost');
define('DB_USERNAME', 'username');
define('DB_PASSWORD', 'password');
define('DB_DATABASE', 'dbname');
$cmd = '/usr/bin/mysql -u '.DB_USERNAME.' --password='.DB_PASSWORD.' -h '.DB_SERVER.' '.DB_DATABASE.' <dump.sql';
passthru($cmd);