Uploading won't work on IIS

Permalink
Hey all,

I have just installed another instance of concrete5 on my server (IIS 7.5). It works great except for one little, but vital thing: uploading files to the files manager. I have tried single upload (error with title "Upload Error" and message "Invalid File") this is the same error that occurs trying to upload with no file selected. Also batch upload doesn't work, it will show the upload bar filled but the uploaded file never appears in the list (there is no error message in this case).

I have given full access to the IUSR and ftp user for that website on all the folders of the concrete5 installation. I have also checked the temp folder in which files get stored during the upload and that folder also gives full access to all IUSR's.

Now i would think that the problem lies with my PHP installation or settings, but that doesn't seem to be the problem as i have other instances of concrete5 running without any problem. This leads me to believe that the problem lies within that specific installation of concrete5.

Any ideas or thoughts are welcome!

Thanks in advance, Manuel

manuelnas
View Replies:
nteaviation replied on at Permalink Reply
nteaviation
There are serveral threads detailing this same issue.

http://www.concrete5.org/community/forums/chat/invalid-file.-messag...

Anyone on this?
nteaviation replied on at Permalink Reply
nteaviation
I have not been able to reproduce this issue. I also checked the bug tracker and did not see anything (but I may have missed it). I run all linux servers, is this specific to IIS?
manuelnas replied on at Permalink Reply
manuelnas
I already found those threads but they are all old and don't have the answer to my problems in them.

I only have the one Windows server, but it seems to be occurring on IIS only. The instances (that i know about) that had this error are resolved by adding something to the "Allowed File Types" or some permissions.
nteaviation replied on at Permalink Reply
nteaviation
Lately it seems that I have been seeing a lot of threads with phrases like "can not upload" and "invalid file". I am starting to think they are all related.
exchangecore replied on at Permalink Reply
exchangecore
I would start investigating where your temporary uploads directory is set to and making sure that it has permissions to that. If that's not it make sure that the actual uploads directory of concrete5 is writable.
manuelnas replied on at Permalink Reply
manuelnas
PHP's temp upload directory settings:

upload_tmp_dir= "C:\Windows\Temp"


And IUSRS (includes all that have IUSR_ prefix) has full rights over this folder. Just to be sure i added the IUSR for the specific website but it didn't help.
akuma6099 replied on at Permalink Reply
I ran into the same issue on a fresh install running on Server 2008 R2 x64. I was trying to upload a simple gif and I kept getting "Invalid File". I'm using FastCGI and have added the open_basedir to "FastCGI Settings" along with the PHPRC environment variable. This lets IIS use the php.ini located in the websites root. Inside my php.ini the upload_tmp_dir was refrencing "C:\PHP5\tmp" which is where PHP is installed. Permissions are correct but Concrete5 doesn't like it. I had to change it to "C:\WebSites\C5\files\tmp" and restart IIS to make the change. Upload worked perfectly after that.

On a side note. Granting IIS_IUSRS permission generally works. But in reality IIS is using the IUSR account for anonymous access(By Default). I have to add IUSR to config, files, and packages in order to pass the run-tests before installation. Meanwhile the website root folder has IIS_IUSRS -> Read, List, Read&Execute. It would not pass until IUSR was added to the 3 folders.