/var/php_sessions and PATH_INFO or ORIG_PATH_INFO FatCow hosting errors

Permalink
I just moved my site to FatCow hosting, before I made that decision I contemplated your hosting, but the price is very high so i decided to go with FatCow.
I called them and made sure they comply with all the requirements to support C5, which i have been using for a couple months now and think is the BEST CMS I really would like to keep using C5 it works perfectly with my production pipeline, and clients love it; however when I was ready to install C5 files to the new host. I found that on the pre-test I am getting these errors, and i have not been able to find a solution for this problem.

Please Help me!! I am in the middle of a huge business restructure and since C5 worked so well, it is in our plans, I would hate to have to go through research and learning another CMS again.

(the process of transferring the domain name has not been completed, that is why the URL is lapiz.fatcow.com, do not know if this could be a reason for the error message, we just want to be ready once the process is completed, but if we have to wait then we will wait)

I have uploaded a info.php just in case, here is the path:http://lapiz.fatcow.com/info.php...

PS:(I have followed all the steps in the installation guide.)

Concrete cannot parse the PATH_INFO or ORIG_PATH_INFO information provided by your server.

Warning: Unknown: open(/var/php_sessions/sess_0834df010e7e902c6b24af3c27fe3a8f, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/php_sessions) in Unknown on line 0

Thank You!

ld13
View Replies:
mbdolan replied on at Permalink Reply
I also use FatCow and got the solution from them. (worked for me anyway)

Login to your control panel then find Scripting and Add-Ons > CGI and Scripted Language Support > PHP Scripting. At the bottom of this page you can edit your php.ini file - change the session.save_path from /var/php_session (or whatever yours is) to the absolute path to your home web directory/cgi-bin/tmp. (i.e. mine is /home/users/web/bXXXX/moo.mydomainname/cgi-bin/tmp). That was all they changed and it fixed the problem. If you have any trouble, just give them a call, they actually made the edits for me, but I could have done it myself faster if I had known how to find the php.ini editor.

Hope this helps.
ld13 replied on at Permalink Reply
ld13
mbdolan,
Thanks so much for reply, I ended up chatting with them and they finally fix it for me (they did not tell me what they did). But thank you so much for taking the time and reply to me. I hope you are as happy as I am with the moocrew, and c5.