very noob - issues uploading an image

Permalink
I have installed C5 from my webhost cpanel.

I can go in an edit a few things, but when I go to upload a 2m file in file manager, I can not click on the are and it asks but when I drop the file in the area available it starts and seems to finish the upload but then I get a message saying "server responded with 500 code".

I have no idea what to do now and not much i've read seems to help much; hence this query.

I am running version 8.1.0 and know not a whole lot about php or the like - but i'm willing to learn with some help

View Replies:
Gondwana replied on at Permalink Reply
Gondwana
It's probably a php upload size limitation. You might be able to change the setting on your server. However, it's probably better not to upload such large images unless you're developing a photography site.
outdoornomad replied on at Permalink Reply
thanks mate!

it is indeed a photography related site so a 2m file is pretty small. what do I have to do to increase my php size limit?

edit: I just checked and from the documentation it says php post default is 50mb - but I am not sure how to see/manipulate that
Gondwana replied on at Permalink Reply
Gondwana
Unfortunately, there's no standard way. There's some discussion here:
https://www.concrete5.org/community/forums/customizing_c5/increase-u...

In particular, looking in c5's dashboard 'environment' report is a good idea, to verify that this is what the problem could be. Then, if you can find a way to increase the size through CPanel or equivalent, that would be better than tinkering directly with .ini or .htaccess files. If your host is nice, they might be able to help.
outdoornomad replied on at Permalink Reply
ive just spent the past 4 hours playing with this - very frustrating!

I went through all of the forums and found a thread with .ini & .htaccess stuff on it and have tried it all; including installing 5.7 and 8.1 from scratch as well.
hutman replied on at Permalink Reply
hutman
If you go to Dashboard -> System & Settings -> Environment Information what is the value for upload_max_filesize and post_max_size?
outdoornomad replied on at Permalink Reply
hey...

post is 8m and upload is 2m
outdoornomad replied on at Permalink Reply
ok I have figured out how to increase upload and post limits to 64m (host only allows 64m before moving you to FTP).

I have gone into environment and Cement says limits have increased to 64m each - but still... when I upload a 4m image, I get a 500 code error...

tried transferring a 1.5m file and got the following error:
{"error":{"message":"Allowed memory size of 134217728 bytes exhausted (tried to allocate 47776257 bytes)"},"errors":["Allowed memory size of 134217728 bytes exhausted (tried to allocate 47776257 bytes)"]}

I'm liking the learning, but this is kind of frustrating!

any further thoughts?
outdoornomad replied on at Permalink Reply
ok cool... the hosting company techs have helped walk me through the fix - had to increase all limits within my version of php on server... seems to be working now.

thanks for everyones help!
Gondwana replied on at Permalink Reply
Gondwana
Glad you've got your upload limits sorted out, but this error sounds like a different one. It could be caused by c5 running out of memory when trying to create thumbnails for very large images. I don't know if there's a standard solution for this; you may need to look around if the problem recurrs.