Why are php-gd and gd not recognized?

Permalink 1 user found helpful
Hi. I am making a second installation after a successful first one. This second server runs Centos 4.9 and Apache 2.0.52. When I access the new installation, an issue is flagged with "Image Manipulation Available" ("Concrete5 erquires GD library 2.0.1 or greater"). I encountered the same problem in my first installation and solved it by installing php-gd and restarting Apache. No luck on the second server. Here are the specs:

yum list | grep "gd.*installed"
gd.i386          2.0.28-5.4E.el4_8.1    installed
php-gd.i386      5.3.10-2.el4.remi      installed

Where should I go from here?

Benoît Gauthier

View Replies:
mesuva replied on at Permalink Reply
First thing I'd check is to see if GD is being properly loaded by apache, by using phpinfo()

Chuck into a php file:

And view the file via a browser.

If GD is loaded, you'll see a section for it, where in particular it will state 'GD Support enabled'.

If it's not there, it's a PHP config problem. I would have though that the yum install would have run any necessary scripts to get it installed, but perhaps you installed something in an order that mixed things up. I'd try uninstalling those two packages and reinstalling.
JohntheFish replied on at Permalink Reply
If your C5 install runs well enough to get to the dashboard, you can use
bgauthier replied on at Permalink Reply
Thanks for your reply (re php-info add-on). While I can put the add-on code on the server, I cannot get passed the C5 install validation screen, so I cannot access it.
bgauthier replied on at Permalink Reply 1 Attachment
Thanks for your prompt reply. I removed and reinstalled gd and php-gd (in that order) and the problem persists. I have attached a pdf of the phpinfo information.
mesuva replied on at Permalink Reply
Your phpinfo doesn't include the GD section, so the module isn't being loaded.

The next thing I'd look at is whether gd is enabled in your php.ini config file, which should be at /etc/php.ini (I think)

In that, look for:
and uncomment it if it is still commented out (normally with a semicolon).
Then restart apache and re-check the phpinfo for a GD section.
bgauthier replied on at Permalink Reply
Hmmm, after careful analysis (and a bit of observation), I found that yum reported PHP 5.3 installed by that phpinfo said that Apache ran PHP 5.2. It turns out that there are two versions of Apache installed on this server and that yum updates affect the non production Apache. I will straighten this mess and I'm sure everything will be fine thereafter.

Thanks for all the help.