Why does "www" disappear ?

Permalink
Hello,

Today I did the whole "domain mapping" thing and it was successful. However, I don't understand why, when I type in "http://www.mydomain.com," o, the address has changed to "http://mydomain.com."

Why does the "www" disappear? It may seem like a silly question but I find it a little annoying. I wish it would show up properly!

Did I do something wrong, and if so is there any way to fix it?

Thanks in advance for any help,

View Replies:
MoonGrab replied on at Permalink Reply
MoonGrab
This is intentional.

Being able to open a website both with www and without it, is a SEO mistake related to duplicate content.
http://www.yoursite.com can be considered as a subdomain, therefore a website with duplicate content.

To avoid it, most people either force redirecting tohttp://www.yoursite.com or stripping the www prefix and redirecting to yoursite.com.

So it's a good thing, don't let it bother you.
osaglam replied on at Permalink Reply
Thanks a lot.
For some reasons, we would like to be visible through the initial url .
Could you please explain us how we could redirect or cancel the duplication please?

Many thanks
Adreco replied on at Permalink Reply
Adreco
Hi,
Google search ".htaccess redirects" or this forum for examples.
You will need ftp access to your server as this is a server function rather than a website.

The following is what I've used in some of my .htaccess files to redirect to www.


RewriteEngine On
Options +FollowSymLinks
# Redirect non-www to www
RewriteCond %{HTTP_HOST} !^www\.(.*)
RewriteRule (.*)http://www.%{HTTP_HOST}/$1 [R=301,L]