With the help of Godaddy, I upgraded - imported my site - now I get error

Permalink 1 user found helpful
With the help of Godaddy, I upgraded - imported my site - now I get this error when trying to access my site . . . Any ideas? (was at 5.7.5.3 went to 5.7.5.9) and imported to thier install of Concrete5

Doctrine\Common\Proxy\AbstractProxyFactory::getProxyDefinition(): Failed opening required '/home/dtsmaster/public_html/cbustown.com/application/config/doctrine/proxies/__CG__ConcreteCoreFileStorageLocationStorageLocation.php' (include_path='/home/dtsmaster/public_html/cbustown.com/concrete/vendor:.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php')

drvonzuko
View Replies:
mnakalay replied on at Permalink Reply
mnakalay
Hello,

did you check if the file /home/dtsmaster/public_html/cbustown.com/application/config/doctrine/proxies/__CG__ConcreteCoreFileStorageLocationStorageLocation.php
was on your server or not?

Normally those files are generated by C using Doctrine entities so maybe, if you can access your dashboard, you can regenerate them.
drvonzuko replied on at Permalink Reply
drvonzuko
Thank you for the response and your observation! Unfortunately for me, I'm not that technical with this stuff, more of a designer/content guy. But it is not letting me into my dashboard.

If I follow the path on the server . . . I get down to the Proxies file and it is empty . . .

Progress: I was able to find the contents of the Proxies file from a back-up I had done. I uploaded them and was able to re-access the Dashboard. However, I still can't see any pages of the site . . . now I get this error:

An exception occurred while executing 'SELECT t0.issID AS issID1, t0.customClass AS customClass2, t0.backgroundColor AS backgroundColor3, t0.backgroundImageFileID AS backgroundImageFileID4, t0.backgroundRepeat AS backgroundRepeat5, t0.backgroundSize AS backgroundSize6, t0.backgroundPosition AS backgroundPosition7, t0.borderColor AS borderColor8, t0.borderStyle AS borderStyle9, t0.borderWidth AS borderWidth10, t0.borderRadius AS borderRadius11, t0.baseFontSize AS baseFontSize12, t0.alignment AS alignment13, t0.textColor AS textColor14, t0.linkColor AS linkColor15, t0.marginTop AS marginTop16, t0.marginBottom AS marginBottom17, t0.marginLeft AS marginLeft18, t0.marginRight AS marginRight19, t0.paddingTop AS paddingTop20, t0.paddingBottom AS paddingBottom21, t0.paddingLeft AS paddingLeft22, t0.paddingRight AS paddingRight23, t0.rotate AS rotate24, t0.boxShadowHorizontal AS boxShadowHorizontal25, t0.boxShadowVertical AS boxShadowVertical26, t0.boxShadowBlur AS boxShadowBlur27, t0.boxShadowSpread AS boxShadowSpread28, t0.boxShadowColor AS boxShadowColor29, t0.hideOnExtraSmallDevice AS hideOnExtraSmallDevice30, t0.hideOnSmallDevice AS hideOnSmallDevice31, t0.hideOnMediumDevice AS hideOnMediumDevice32, t0.hideOnLargeDevice AS hideOnLargeDevice33 FROM StyleCustomizerInlineStyleSets t0 WHERE t0.issID = ?' with params ["67"]: SQLSTATE[42S22]: Column not found: 1054 Unknown column 't0.backgroundSize' in 'field list'
mnakalay replied on at Permalink Reply
mnakalay
it looks more and more like a botched upgrade.

Can you check the file application/config/update.php. Check if you have something in it like this:
<?php
return [
    'core' => 'concrete5-x.x.x',
];

x.x.x should be a version number like 8.1.0
If you do, look at the folder updates you should have another folder named like what you have in the update.php file: concrete5-x.x.x
And inside that folder, you should have a folder concrete

If update.php is empty but you have the folders inside the updates folder then add the code in it
drvonzuko replied on at Permalink Reply
drvonzuko
When I check the file path . . . application/config/update.php
There is no update.php file
There is no Concrete file in config either
Within the config/ I only see the following files:
doctrine
generated_overides
app.php
database.php

And . . . the updates file is empty.

When I use the Dashboard I can see all of the pages are still there and in the DB I can see all the images but Concrete can't display any pages or any part of the site.
mnakalay replied on at Permalink Reply
mnakalay
can you manually empty the folder application/files/cache? Just delete everything inside it and see if it fixes the problem
drvonzuko replied on at Permalink Reply
drvonzuko
Tried it, deleted all files in application/files/cache get same error.

I'm wondering, could it have anything at all to do with my Template? I'm using Brimstone.
When I look at site map and at pages all the page names are there. It seems to know there is a site structure sitting there. It just won't fire-up or display any part of the site.

I noticed something when I checked environment - this doesn't seem right?
# concrete5 Version
Core Version - 5.7.5.6
Version Installed - 5.7.5.3
Database Version - 20151221000000

Everything else I see says I'm 5.7.5.6



I greatly appreciate your help on this. I'm at a loss for ideas.

Gary
weyboat replied on at Permalink Reply
weyboat
Hi Gary
Did you make a backup of your complete file system and your database file?
drvonzuko replied on at Permalink Reply
drvonzuko
Yes I did backup before GoDaddy did their thing.
mnakalay replied on at Permalink Reply
mnakalay
maybe you should just restore your backup