Autonav help with Internationalization

Permalink 2 users found helpful
I have a problem with the AutoNav using the Internationalization add-on.

I used to have:

Home | Business | anotherLink etc..

When I apply the add-on this changed to:

English | Italian etc...

Now I can change the auto-nav to second level however because "home" is the actual page "english" it's on the top level so it only loads up:

Business | anotherLink.

Is there anyway you can get the home page link on the navigation bar as well as the other links?

View Replies:
sentinode replied on at Permalink Reply
you can set exclude from nav parameter and then set a different base for AutoNav in every language section instead of root.

In fact the "internationalization" extension has a broken logic and the free version gives you nothing you can't do in Concrete5 without a custom extension (just by adding different trees for each language, and a "1 level deep" navigation for the language switcher).

Nothing like REAL internationalization solutions built into other CMSs..

Their "Enterprise" version price is ridiculous also...

Also, a question for the core team.. - do you plan to include REAL internationalization into Concrete5 core? By REAL I mean the ability to translate each and every string used, and customizing autonav atc components to work with multilanguage. Even better if no separate trees would be needed and the language versions could be used within one tree.
DianaAyub replied on at Permalink Reply
DianaAyub
hi, I'm new to all of this so u'll have to be patient with me...
what do you mean by ' "1 level deep" navigation for the language switcher' ? how do i do that?
nickratering replied on at Permalink Reply
nickratering
I'm having the same issue as willtwinny, no 'home' in the autonav.
I've tried to add it manually in a custom template, with the 'parent' statements, but that will break when entering the third level.

Here's what I had so far:

$parentpage = Page::getByID($c->getCollectionParentID()); 
$parenturl = $parentpage->getCollectionPath();
echo("<ul class=\"nav-header\">");
// home back in nav
echo("<li><a href=\"".$parenturl."\">");
print $parentpage->getCollectionName();
echo("</a></li>");


Any ideas?
DianaAyub replied on at Permalink Reply
DianaAyub
I also had this issue.
I couldn't find an exact solution to it but I found a way around it.
I assigned the attribute "exclude from nav" to the home pages of each language and underneath each home page I created another page exactly like the homepage. now what happens is that when you first go to the site, you enter the actual homepage but the "home" button that appears in the autonav takes you to the duplicate page you created below the homepage.
you have to remember to make your edits to both pages though...

hope this helps :)
nickratering replied on at Permalink Reply
nickratering
That's a good workaround, altough it's not exactly what you'd like to happen.
Maybe you can alias the language homepages, instead of copying, so you won't have to edit twice.
pvernaglia replied on at Permalink Reply 1 Attachment
pvernaglia
Try this autonav template
nickratering replied on at Permalink Reply
nickratering
Yes!! This does it!! I will check the code how you've done this!
Thank you very much!!
Best answer!
DianaAyub replied on at Permalink Reply
DianaAyub
wait... how do i alias the pages?? i'm new and this i diidn't know i could do!
nickratering replied on at Permalink Reply
nickratering
Hi!
Just drag a page-icon in the sitemap on a parent and choose 'Alias'.
More about this check:http://www.concrete5.org/documentation/general-topics/site-tree/...

Goodluck!
DianaAyub replied on at Permalink Reply
DianaAyub
haha so simple it flew right by me! thankyou :)
DianaAyub replied on at Permalink Reply
DianaAyub
hi!
what part of the php code you attached do i need to include the parent in the autonav? because i am already using a customized php code and i can't replace the whole thing.
sacp replied on at Permalink Reply
sacp
Hi.

Where should this file go ?

Thanks
mikey89 replied on at Permalink Reply
The file is a template, so you can eather copy it into the concrete5 autonav module (this would be in "concrete/blocks/autonav/templates"), or you copy it into the blocks folder so you make clear that this is your own template for the autonav block.
This would be "blocks\autonav\templates".

I prefer the second option becuase you can be certain that on an update of the autonav module itself, your file won't be overwritten.