Call to a member function getCollectionID() on boolean

Permalink
Hi, just as soon as I set a parent page to any language using the Multilingual Setup in the Dashboard I get the following error when I try to visit the any page:

Call to a member function getCollectionID() on boolean

Does anyone know how this can be fixed?

Thanks,
Luca

ZillionProductions
View Replies:
Resipisco replied on at Permalink Reply
Resipisco
I have similar issues with setting up multilingual pages. But I can't find any helpful documentation about this feature is working and how it should be used properly.
I hope there will be one who can answer on it. But sorry I cant help you.
Resipisco replied on at Permalink Reply
Resipisco
Update:
After endless try outs I got a strange solution for my similar issue. But my error was "Call to member function getCollectionID() empty object" or so. And I got this only if I tried to visit my "Home" page, where I had no language section. All other pages with language section worked fine.
Today I've checked my theme options (Supermint3 theme) and found an option at "Miscalenous" > "Activate iFrame z-index script" : ON/OFF
I've switched it OFF and my problem was gone. Now I can switch it ON and the problem keeps solved.
Maybe that helps you as well, please check.
ZillionProductions replied on at Permalink Reply
ZillionProductions
Hi, thanks for the feedback! I just figured out (after some internet research) that the Global Areas were a problem. For some reason I had clear the areas, setup the language and then setup the global areas again... Now this works so I'm unable to reconstruct the error and give your solution a try!

Anyway, thanks for sharing, hopefully this post will help many others ;)

Thanks a have a great day,
Luca