index.php

Permalink
hello friends!

I've recently enable this option to remove index.php from url:

dashboard->sitewide settings->enable pretty url's.

but didn't copy that code in .htaccess, now i am not even able to login and change settings.

none of my pages access except home page.

help me!

View Replies:
victorcis replied on at Permalink Reply
Hi,

PM Sent.

Victor
edbeeny replied on at Permalink Reply
edbeeny
Add this to your .htaccess

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
</IfModule>
c5dragon replied on at Permalink Reply
c5dragon
or this to your application/config/concrete.php
<?php
return array(
    /**
     * --------------------------------------------------------------------
     * SEO settings
     * --------------------------------------------------------------------
     */
    'seo' => array(
        'url_rewriting'           => false,
        'url_rewriting_all'       => false
    )
);