Requested URL not found

Permalink
Just found out that all of the pages of my site except the homepage return the following error:

Not Found

The requested URL /dja-clients/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Any ideas why?
http://www.davidjamesagency.com

View Replies: View Best Answer
tallacman replied on at Permalink Reply
tallacman
Looks like you need to enable pretty urls.
Your page is available here:
http://www.davidjamesagency.com/index.php/about-dja/...
Pretty url will get rid of the index.php
DJAdave replied on at Permalink Reply
Thanks. It looks like i have Pretty URLs turned on. Maybe I should turn it off?

Here's the code that goes with it...see anything here?

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
</IfModule>
tallacman replied on at Permalink Best Answer Reply
tallacman
Yes. Go to the dash and turn it off and then turn it back on. That always works.
hereNT replied on at Permalink Reply
hereNT
Well, always works if you have mod_rewrite enabled on the server... ;)
DJAdave replied on at Permalink Reply
Genius!!! That worked!
TMDesigns replied on at Permalink Reply
TMDesigns
Your site has a weird www . www. thing going on. Might want to look into that. You have a redirect in place for http://www.davidjamesagency.com to go to http://www.www.davidjamesagency.com...
besan replied on at Permalink Reply
Hi
I am having a same problem
Requested URL not found
Permalink
Just found out that all of the pages of my site except the homepage return the following error:

Not Found

The requested URL /index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
i have disable for Pretty URLs, so the url to pages returned to work but sub pages still not working
Any ideas why?
if you click any image in this page problem appears

http://samills.com/public_html/index.php/recipes/...
jbx replied on at Permalink Reply
jbx
Slightly different situation for you. You seem to have your site inside a subdirectory called public_html. I'm not sure you should have that directory uploaded to the server at all. However, your links are not including the public_html directory, and so are not found.

Ideally, you probably need to move your site outside of that public_html directory.

Jon
besan replied on at Permalink Reply
i move your site outside of that public_html Previously but The problem still exists.
jbx replied on at Permalink Reply
jbx
Clearly not fully, because the link you provided still points to the site inside public_html.

Would you like me to fix the issue for you? If so, send me a PM and I'll send you my quote to get it working correctly.

Jon
mhawke replied on at Permalink Reply
mhawke
Two things...

First, are you looking to hire someone to fix this for you? The 'Jobs' forum is used to ask for paid help. If you are looking for general suggestions, you should post your question in the regular forums.

Second, did you create a folder off the root called 'public_html' for your new concrete5 installations? I have no idea what unintended consequences that might cause to the Pretty URL logic. Also, I would find it quite confusing (and therefore dangerous) to have 2 'public_html' folders. You're one wrong mouse click from deleting important files from the wrong public_html folder.
TMDesigns replied on at Permalink Reply
TMDesigns
Hi,

You just need to get the directory structure right with the site config.

I can help you with this if you like it shouldn't be more than an hours work.

If you are interested in paying me to fix this please PM me or email me on [email protected]

Tim
grafoman replied on at Permalink Reply
I recently got this message when transfering a site (from FTP to FTP). Turns out i forgot to move the .htaccess file!