Dashboard / backend problems (css not showing, access denied and similar)

Permalink
Hi you concrete persons,

I hope to find some help for our website, as I have no webhosting background, I am quite lost at the moment.

Following situation:
- Concrete 5.6.3.3., hosted on external server (1und1.de)
- Frontend of website is running smoothly
- In Backend of website the following problems occur (logged in as Superadmin):

1. in editing mode, can't click on normally editable modules, the "hand" mouse does not appear. Instead only the normal text arrow (looking like a serified I) appears. Except for the very upper left corner of every box, there I can click and get the menu with "edit", "delete" etc.
(see screenshot acs1)

2. when in actual editing of a module/block, the normal backend CSS is missing. There is a grey circle icon (js?) loading forever. Clicking any link does nothing, no action. So I can't edit any content as the backend is not responsing to input except for the text field.
(see screenshot acs2)

3. when clicking on sitemap, the grey circle icon is again appearing, loading endlessly with no result
(see screenshot acs3)

4. when using the flat sitemap view, I can access the singular pages. When clicking the menu, e.g. preferences ("Eigenschaften"), I get an access denied error.
(see screenshot acs4 and 5)

5. When accessing phpmyadmin and exporting the database, the sql file is 250 MB. Older backups had 6 MB.

6. When trying to upload an old (+1y) backup of sql via phpmyadmin I either get a Bad Gateway or "SQL query: DROP TABLE IF EXISTS AreaPermissionAssignments; MySQL said: #1046 - No database selected"


_____________

/root/config/site.php looks like this:
<?php define('DB_SERVER', 'localhost:/tmp/mysql5.sock');
define('DB_USERNAME', 'xxxx');
define('DB_PASSWORD', 'xxxx');
define('DB_DATABASE', 'db526837688');?>
<?php define('DIRNAME_APP_UPDATED', 'concrete5.6.3.3');?>

/root/index.php is:
<?php require('concrete/dispatcher.php');

/root/php.ini is empty

TO SUM UP: Looks like some sql problems and/or some JS problems - and I have no clue at all of these things.

Glad for any help!

Best
Tom

5 Attachments

Tomaszl
View Replies:
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
I would fix the database bloat as a first priority.
Go to systems & Settings/Statistics and turn off "Track page view statistics."
Next go to Full Dashboard/Logs and clear all logs.

Next go to phpMyAdmin select the PageStatistics table by placing a tick in the box on the lefthand side, next at the bottom of the page in the 'With selected' box, click Empty table.
Whilst you are in phpMyAdmin check the table sizes to see if any other tables are bloated and make a note of them, (you might need to do the same with the DownloadStatistics table).
Now try your site again as this may be all you need to do...
Tomaszl replied on at Permalink Reply
Tomaszl
Thank you very much for your fast reply! Track page view has already been disabled. I deleted the logs and the emptied page statistics in phpmyAdmin, which were the only folder bloated. So that worked well.

Checked re-uploading the 1y old backup - this worked now, too. But it does not solve the problems in the backend. The rest of the system still has the issues described above.

And in addition: Now I can't re-import the latest sql backup with the current set-up of the page. So my page now shows content from January 2016.


The error says:

--
-- Daten für Tabelle `Areas`
--

INSERT INTO `Areas` (`arID`, `cID`, `arHandle`, `arOverrideCollectionPermissions`, `arInheritPermissionsFromAreaOnCID`, `arIsGlobal`) VALUES
(1, 106, 'Header', 0, 0, 0),
(2, 106, 'Column 1', 0, 0, 0),
(3, 106, 'Column 2', 0, 0, 0),
(4, 106, 'Column 3', 0, 0, 0),
(5, 106, 'Column 4', 0, 0, 0),
(6, 107, 'Primary', 0, 0, 0),
(7, 107, 'Secondary 1', 0, 0, 0),
(8, 107, 'Secondary 2', 0, 0, 0),
(9, 107, 'Secondary 3', 0, 0, 0),
(10, 107, 'Secondary 4', 0, 0, 0),
(11, 107, 'Secondary 5', 0, 0, 0),
(12, 1, 'Header Nav', 0, 0, 0),
(13, 1, 'Header', 0, 0, 0),
(14, 1, 'Sidebar', 0, 0, 0),
(15, 1, 'Main', 0, 0, 0),
(16, 1, 'ImageOrFlash', 0, 0, 0),
(17, 1, 'Page-Title -> predefine as Plain Text in Page Defaults', 0, 0, 0),
(18, 1, 'Content', 0, 0, 0),
(19, 135, 'Stage', 0, 0, 0),
(20, 135, 'header', 0, 0, 0),
(21, 135, 'Page_List_News', 0, 0, 0),
(22, 135, 'Teaser-Leiste -> predefine as Allianz Floating Category', 0, 0, 0),
(23, 137, 'Action-Buttons', 0, 0, 0)[...]
MySQL meldet: Dokumentation

#1062 - Duplicate entry '1' for key 'PRIMARY'

Thank you so much for your help!
JohntheFish replied on at Permalink Reply
JohntheFish
You can only import a database backup into an empty database. You error looks like you may have imported it on-top of existing data.
Tomaszl2 replied on at Permalink Reply
Tomaszl2
Thx John, indeed, after clearing the DB the upload of the sql file worked. Hard to get used to these things when only taking care of it once a decade :)

The other issues in the backend described above are still there. Any ideas on those?

Thanks
Tom


(new account as the forum blocked mine, maybe some strange spam detection?)
JohntheFish replied on at Permalink Reply
JohntheFish
Have a look at my Exteme Clean job addon
https://www.concrete5.org/marketplace/addons/extreme-clean...

The other errors you describe could be secondary issues cause by a javascript error or broken html in something you have added. They may be resolved by recovering from backup.

See what remains after cleaning and post again what problems remain.
Tomaszl2 replied on at Permalink Reply
Tomaszl2
Thanks for your suggestion - unfortunately I can't install addons as the backend does not react to my inputs in that directory... :/

Lost in translation, kind of! :)

Any other thoughts?

How about re-installing 5.6.3.3?

Thanks
Tom
JohntheFish replied on at Permalink Reply
JohntheFish
Looking at your last few screenshots in detail, I suspect this may be a long term bug in the multilingual addon. In a few places it tries to open language files that don't exist.
Last time it happened to me was following a 'login as' another user from site admin and that user having a default language there was no translation files for. Perhaps it is something to do with en_US being hard coded in a few places. Some code using the multilingual_text helper then broke because further behind the scenes it called the default language helper and the default language helper got it wrong and locked the entire site up.

I got round it by temporarily short circuiting the default language helper. That enabled me to get into the dashboard and change the default language to en_US, rework some code that used the multilingual_text helper and then switch back to the actual site language.

Unfortunately I can't remember the details of how I hacked it.
Tomaszl2 replied on at Permalink Reply
Tomaszl2
Thanks again!

As I can't change these settings at the moment, I will talk with the guys who set the page up in the beginning. I'll report what comes out of it :)

Best
Tom