Server Error 500 after moving to new hosting service

Permalink
Dear friends,

I have moved my clients websitehttp://www.woodvilleindia.com to a new hosting provider and my mistake is that i forgot to switch off pretty urls and cache before backup. Initially i got a message of internal configuration error 500. When I checked the errors in Cpanel it said invalid command 'SuPHP_ConfigPath" misspell or defined.... etc etc .... in .htaccess. My htaccess file has following codes. After i put # on the suPHP command and deleted my cache and cache_objects folder my site started up but was broken as you can see now. Can you please me before my client starts to freak out.

----htaccess--------------
#suPHP_ConfigPath /home/woodvill/public_html
<Files php.ini>
order allow,deny
deny from all
</Files>   
<IfModule mod_rewrite.c>
   RewriteEngine On
   RewriteBase /
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteRule ^(.*)$ index.php/$1 [L]
   </IfModule>

------- htaccess end-----

A brief background. My site is currently running concrete 5.5.2.1... It was upgraded from previous versions. I am able to login page by putting "/index.php" but after login some errors prevent from entering the dashboard.

The site.php ibn config folder has following code if its helps

----------------site.php--------
<?php 
define('DB_SERVER', 'localhost');
define('DB_USERNAME', 'woodvill_vip');
define('DB_PASSWORD', 'xxxxxxxxxxx');
define('DB_DATABASE', 'woodvill_woodville');
define('BASE_URL', 'http://www.woodvilleindia.com');
define('DIR_REL', '');
define('PASSWORD_SALT', 'XfU9Pvbpn1wqFcBV6IZ5hWNsHEg4K2hasdksdklqkljw35lvasl');
?><?php ?><?php define('DIRNAME_APP_UPDATED', 'concrete5.5.2.1');?>

--------------site.php end------------------

Can you guys please help me restore my clients site... ITS VERY URGENT. Homepage is broken. Internal pages is broken, screenshot attached. Screenshot of error after login also attached.

Warm regards
Vipin

3 Attachments

View Replies: View Best Answer
hutman replied on at Permalink Reply
hutman
Sometimes this can be caused by extra PHP tags, do the errors go away if you change your site.php to

<?php 
define('DB_SERVER', 'localhost');
define('DB_USERNAME', 'woodvill_vip');
define('DB_PASSWORD', 'xxxxxxxxxxx');
define('DB_DATABASE', 'woodvill_woodville');
define('BASE_URL', 'http://www.woodvilleindia.com');
define('DIR_REL', '');
define('PASSWORD_SALT', 'XfU9Pvbpn1wqFcBV6IZ5hWNsHEg4K2hasdksdklqkljw35lvasl');
define('DIRNAME_APP_UPDATED', 'concrete5.5.2.1');
toonsters replied on at Permalink Reply
I changed it to the above mentioned .. but still my site is broken. Please someone help me urgently.
ConcreteOwl replied on at Permalink Best Answer Reply
ConcreteOwl
Your site.php has a BOM (Byte Order Mark) at the beginning of the file, you should edit the file and ensure your html editor is set to not include unicode signature (BOM).
Or, you could edit it with a basic notepad program.
If you want me to do this for you.. PM me the login details to the file system..
Regards
weyboat
toonsters replied on at Permalink Reply
Thank you David, I have messaged you the details as need. Do let me know if anything else would be required.
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
All sorted, you are good to go..
toonsters replied on at Permalink Reply
Thank you so much for you support. But there are still some issues. I have messaged you
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
I have replied to your message..
You say the site is working fine but appears to be an older version..
This can only be because of the database file used to restore the site is an older version.
I don't have access to the server or access to login to the site, so you will have to check to see which database file was used when you transferred the site to the new server.
There was indeed a BOM (Byte Order Mark) at the beginning of the site.php file and this was removed.
I would strongly recommend that what ever html editor you used to edit the site.php file is NOT set to include a unicode signature (BOM) when editing php files, you should find the setting in the html editor preferences section.