Subpages Have Stopped Loading

Permalink
I have inherited a concrete5 web site that has just recently stopped loading subpages and is giving "Page Not Found - No page could be found at this address. " When logged in as admin, I can see the pages in full sitemap and the indexer.php links will bring up the page out of the database. But there seems to be a new mapping problem form the easy to remember names (canonical I think the term is) to the actual ID for the page to be displayed. I've done a site backup and mysqldump to peruse offline. Any hints on what to look for?

# concrete5 Version
5.6.3.4

# concrete5 Packages
Blog Thumbnail (1.0), Dae Marquee (2.0.4), EcoGreen (1.0.0), Eloquent (1.0.2), Email Obfuscator (2.0), Extended Search (1.0), Manual Nav (1.3), Next & Previous (1.02), Parent Area (1.1.1), Publication Link (0.9.0), Snapshot (1.0), Urban Artist (1.0.2).

# concrete5 Overrides
css/custom.css, themes/view.php, themes/elements, themes/main.css, themes/left_sidebar.php, themes/thumbnail.png, themes/index.html, themes/full.php, themes/default.php, themes/greek_yogurt, themes/css, themes/blog_entry.php, themes/typography.css, themes/images, themes/description.txt

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - On - In all cases.
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Apache

# Server API
cgi-fcgi

# PHP Version
5.2.17

# PHP Extensions
apc, bcmath, calendar, cgi-fcgi, ctype, curl, date, dba, dom, exif, filter, ftp, gd, gettext, hash, iconv, json, libxml, mbstring, mcrypt, mhash, mysql, mysqli, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, pspell, Reflection, session, SimpleXML, soap, SPL, SQLite, standard, tokenizer, wddx, xml, xmlreader, xmlwriter, xsl, zip, zlib.

# PHP Settings
max_execution_time - 30
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
memory_limit - 64M
post_max_size - 33M
safe_mode - Off
safe_mode_exec_dir - /usr/local/php/bin
safe_mode_gid - Off
safe_mode_include_dir - ~
sql.safe_mode - Off
upload_max_filesize - 32M
apc.max_file_size - 1M
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
pcre.backtrack_limit - 100000
pcre.recursion_limit - 100000
session.cache_limiter - nocache
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
safe_mode_allowed_env_vars - PHP_ LANG LANG_
safe_mode_protected_env_vars - LD_LIBRARY_PATH
_SERVER["userlimit_name"] - 9104693
_SERVER["userlimit_limit"] - 50

View Replies: View Best Answer
hutman replied on at Permalink Reply
hutman
1) have you tried deleting everything in /files/cache? Manually - not through the dashboard
2) have you tried clearing the cache through the dashboard?
3) Is your .htaccess file still in place on your server?
4) Do the sub pages work if you turn off pretty urls?
parrottgreg replied on at Permalink Reply
Wow! thanks for the list...

1) have not tried manual cache clear. I'll do that next.
2) I did try this... no improvement
3) I will look. I know I've seen several .htaccess files in my backup. This would need to be at the root I assume.
4) I didn't know there was an option for that. I'll try that after 1 and 3.

Thanks!

GP

-----Original Message-----
From: concrete5 Community [mailto:[email protected]]
Sent: Friday, October 13, 2017 12:31 PM
To: [email protected]
Subject: Subpages Have Stopped Loading : Legacy (version 5.6.x-)
parrottgreg replied on at Permalink Reply
Update:

1) did not help
2) tried yesterday and did not help
3) still there in webroot
4) turned off via dashboard, BUT, it did not update .htaccess. I did that manually. Do I need to somehow restart something? I cleared the browser cache and the pretty URLs are still there.

GP
hutman replied on at Permalink Best Answer Reply
hutman
Try turning off the Pretty URLs in the Dashboard, clearing the cache in the dashboard, and deleting your .htaccess in the webroot, do the subpages work (without the pretty url of course) this way?
parrottgreg replied on at Permalink Reply
That "almost" works. If I got to the base page, the links in the navigation are still pretty. But if I force the browser to a subpage by inserting /index.php/, the subpage opens and all the nav links have the embedded /index.php/ text in them. Is there a way to "rebuild" the base page to include this? That would be an acceptable workaround for me until I can figure out why the pretty urls don't work.
hutman replied on at Permalink Reply
hutman
Can you provide a link to your site? It almost sounds like the developer hard coded the pretty urls instead of using an autonav block.
parrottgreg replied on at Permalink Reply
PM sent.