Add block not working after update

I recently updated from 5.5 to 5.6 and am now unable to add any new blocks. The add content block just spins and spins and spins. I can add a new design and layout and I can edit previous blocks.

I purchased my theme from the marketplace and have another site that uses the default theme. The add blocks on the default theme work fine but since the update my purchased theme is useless without the ability to add new content.

Help please!

View Replies:
Arequal replied on at Permalink Reply
Did you refresh and/or disable cache?
inkhorn replied on at Permalink Reply
Yes, it didn't work. I'm waiting for the host to restore what they now have broken! What a day!
Arequal replied on at Permalink Reply
When you get the spinning item, is the database updated with the new block?
Can you debug PHP code by using Netbeans, for instance?
Did you read the PHP log?

Just some ideas.
inkhorn replied on at Permalink Reply
LOL! As a nontechie, of course, not. How do I update the new block? And what is Netbeans? And, while I do know how to find the PHP log if I read it I wouldn't know what to look for if something was missing.

Can you instruct me in how to update a new block? Perhaps I can try that first?
Arequal replied on at Permalink Reply
Well, maybe I supposed you had a developer's profile, so sorry for going so fast.

First of all, you should make sure that the new block was added, but for some reason the spinning thing got frozen. If it happens, well, maybe refreshing your browser and the new block comes up!

Netbeans is a development environment:
If you install and use Netbeans you can run Concrete step by step, and find out why it fails.

And the PHP log can be enabled by editing the server configuration, usually the php.ini file, "error_log" entry
inkhorn replied on at Permalink Reply
I do appreciate your help!

I have refreshed several times but that doesn't work. I'll try your other suggestions and see if that works.
inkhorn replied on at Permalink Reply
How to I upload a new block? I've downloaded but as a non-techie it'll take me some time to learn how to use it properly.

Thank you so much for your help... all I want to do is add content using a block... help oh help oh help pleeeease! LOL!
miguelgilmartinez replied on at Permalink Reply
Have you tried to use another browser? If you are using an old version you
can have issues with this
inkhorn replied on at Permalink Reply
I did try safari and explore and neither work.

Strangely, I have another site with a different theme and don't have any problems adding a block. I've cleared caches, refreshed, unchecked boxes in the caches and still the spinning block continues.

It may be tied into the theme and I've requested help from the creator but no response ... AND ... when I tried a different theme it also gave me a spinning block so I'm thinking it may not be the theme but somewhere in the code.

I can edit block that are already there but I cannot add anything. I'm so disappointed and don't know as a newbie how to remove everything safely and reconnect it to see if it's a glitch.

I've looked at the php block but wouldn't know if something was wrong if it stared me in the face.

Any other suggestions please???
Arequal replied on at Permalink Reply
So, if you tried with the default theme (did you?) and the problem persists, we can discard it is a conflict between block and theme.

Did you look at the Concrete5 logs in the dashboard panel?
inkhorn replied on at Permalink Reply
Under the environment setting that has logging both areas are checked:

Log Application Exceptions
Log Emails Sent

Is this the area you are referring to? There's also an area that says login destination.
inkhorn replied on at Permalink Reply
I did find the area that says logs and it reads:

Exception Occurred: mysql error: [1054: Unknown column 'Pages.ctID' in 'field list'] in EXECUTE("select Pages.cID, Pages.pkgID, Pages.cPointerID, Pages.cPointerExternalLink, Pages.cIsActive, Pages.cIsSystemPage, Pages.cPointerExternalLinkNewWindow, Pages.cFilename, Collections.cDateAdded, Pages.cDisplayOrder, Collections.cDateModified, cInheritPermissionsFromCID, cInheritPermissionsFrom, cOverrideTemplatePermissions, cPendingAction, cPendingActionUID, cPendingActionTargetCID, cPendingActionDatetime, cCheckedOutUID, cIsTemplate, uID, cPath, Pages.ctID, ctHandle, ctIcon, ptID, cParentID, cChildren, ctName, cCacheFullPageContent, cCacheFullPageContentOverrideLifetime, cCacheFullPageContentLifetimeCustom from Pages inner join Collections on Pages.cID = Collections.cID left join PageTypes on (PageTypes.ctID = Pages.ctID) left join PagePaths on (Pages.cID = PagePaths.cID and PagePaths.ppIsCanonical = 1) where Pages.cID = '370'")

#0 /home6/thewriv8/public_html/updates/concrete5.5.1/concrete/libraries/3rdparty/adodb/ adodb_throw('mysql', 'EXECUTE', 1054, 'Unknown column ...', 'select Pages.cI...', false, Object(ADODB_mysql))
#1 /home6/thewriv8/public_html/updates/concrete5.5.1/concrete/libraries/3rdparty/adodb/ ADOConnection->_Execute('select Pages.cI...')
#2 /home6/thewriv8/public_html/updates/concrete5.5.1/concrete/libraries/3rdparty/adodb/ ADOConnection->Execute('select Pages.cI...', Array)
#3 /home6/thewriv8/public_html/updates/concrete5.5.1/concrete/models/page.php(73): ADOConnection->Query('select Pages.cI...', Array)
#4 /home6/thewriv8/public_html/updates/concrete5.5.1/concrete/models/page.php(52): Page->populatePage('370', 'where Pages.cID...', '1')
#5 /home6/thewriv8/public_html/updates/concrete5.5.1/concrete/models/stack/model.php(103): Page::getByID('370', 'ACTIVE', 'Stack')
#6 /home6/thewriv8/public_html/updates/concrete5.5.1/concrete/models/stack/model.php(74): Stack::getByID('370', 'ACTIVE')
#7 /home6/thewriv8/public_html/updates/concrete5.5.1/concrete/models/collection.php(714): Stack::getByName('Header Nav', 'ACTIVE')
#8 /home6/thewriv8/public_html/updates/concrete5.5.1/concrete/libraries/view.php(769): Collection->getGlobalBlocks()
#9 /home6/thewriv8/public_html/updates/concrete5.5.1/concrete/dispatcher.php(274): View->render(Object(Page))
#10 /home6/thewriv8/public_html/concrete/startup/updated_core_check.php(6): require('/home6/thewriv8...')
#11 /home6/thewriv8/public_html/concrete/dispatcher.php(20): require('/home6/thewriv8...')
#12 /home6/thewriv8/public_html/index.php(2): require('/home6/thewriv8...')
#13 {main}

inkhorn replied on at Permalink Reply
Here's another one dated 3/21/13 the first one was from 3/24/13:

Exception Occurred: /home6/thewriv8/public_html/updates/concrete5.6.1.1/concrete/core/controllers/blocks/form.php:256 Oops, something is wrong with the form you posted (it doesn't have a question set id). (0)

#0 /home6/thewriv8/public_html/updates/concrete5.6.1.1/concrete/core/models/block.php(411): Concrete5_Controller_Block_Form->action_submit_form()
#1 /home6/thewriv8/public_html/updates/concrete5.6.1.1/concrete/startup/process.php(283): Concrete5_Model_Block->passThruBlock('submit_form')
#2 /home6/thewriv8/public_html/updates/concrete5.6.1.1/concrete/dispatcher.php(244): require('/home6/thewriv8...')
#3 /home6/thewriv8/public_html/concrete/startup/updated_core_check.php(6): require('/home6/thewriv8...')
#4 /home6/thewriv8/public_html/concrete/dispatcher.php(20): require('/home6/thewriv8...')
#5 /home6/thewriv8/public_html/index.php(2): require('/home6/thewriv8...')
#6 {main}