Create Package Installation Data for Themes

Permalink 1 user found helpful
Hello,
since version 8 i am helpless to create the installation data for content swap (content.xml + content files).

Andrew has created a addon that was perfectly working on 5.7:
https://github.com/concrete5/addon_sample_content_generator/...

The add-on is using the Core class Concrete\Core\Backup\ContentExporter for creating the installation data. But since 8 the methods are deprecated and when i try to create content swap data i get the error message "Please use the migration tool". But where i can find the Migration tool? Does it have the same possibilities? Or do i have to develop themes on 5.7 if i want to create sample data?

Thank you.

fabianbitter
View Replies: View Best Answer
Steevb replied on at Permalink Reply
Steevb
Had the same issue.

For my new theme package I had to create my package for 5.7.5+, not 5.8.2.1, and test, then use the 'sample_content-generator' for 5.7.

My new theme package with xml, etc worked ok for 5.8.2.1.

Hope that helps.
MrKDilkington replied on at Permalink Best Answer Reply
MrKDilkington
Hi fabianbitter,

Here is a link to the migration tool.
https://github.com/concrete5/addon_migration_tool...
fabianbitter replied on at Permalink Reply
fabianbitter
Thank you both. For my current project i developed the theme with 5.7 but for the future the migration tool is a very helpful :)