custom theme not showing admin toolbar at top of page

Permalink 1 user found helpful
Hello Everybody.

I'm trying to convert a site design into a theme for C5.5.2, but I'm having trouble. I followed the instructions found here:http://www.concrete5.org/documentation/how-tos/designers/converting... and also here:http://www.concrete5.org/documentation/how-tos/designers/make-a-the... and the theme installs and displays correctly. However, when I login as an admin, there is no admin toolbar at the top of the page. The line
<? Loader::element('header_required'); ?>
is in the header as instructed, but still no admin bar. I stripped out all of the custom css and javascript, but still no bar.

Any ideas what might be causing this?

spjuphigh
View Replies: View Best Answer
mkly replied on at Permalink Best Answer Reply
mkly
As of 5.5 you also need to include
<?php Loader::element('footer_required'); ?>

somewhere in your footer. This was also requried in 5.4 but no one really did it but now the toolbar and some other things use it.
spjuphigh replied on at Permalink Reply
spjuphigh
That did it. THANKS!!
brandonx49 replied on at Permalink Reply
brandonx49
Fixed my issue too. Thanks!
webporter replied on at Permalink Reply
webporter
helped me too! :)
jdch replied on at Permalink Reply
I apologize now i am new to all of this especially coding! I have just about killed myself building a site i kinda like it:) now when i go in to edit make changes the edit bar is gone just as you guys are talking about. After hours with bluehost no change but did finally see how to add code in header and footer. I simply hit return and added
<? Loader::element('header_required'); ?>
to the first line of code under the header folder. and again for the footer save changes. went back to log in to make changes no edit bar! it is there for a second just a blank white bar then it goes away! any more help would be amazing! thank you doug
jdch replied on at Permalink Reply
wow wow wow after a stiff drink I figured out the missing edit bar issue that has been killing me and others!
cloudflare! thanks a lot for a day full of #$%@#$^%@#
Minification: if you choose just about anything other than css only or
rocketloader
it causes this missing edit bar issue!
tduncandesign replied on at Permalink Reply
tduncandesign
I also ran into this issue today, on a long-standing Concrete 5 5.6 site, hosted off Media Temple grid service, the Toolbar disappeared in Chrome, though it would load in Safarti and IE... I disabled just the RocketScript (beta) portion of CloudFlare, and the toolbar came right up as advertised on the tin. Yay. Maybe this helps someone else searching...

edit: I meant "RocketLoader"

edit too: Also have a C5 5.7 site on MT grid, and it has RocketLoader enabled, no apparent issues there... fwiw...
tduncandesign replied on at Permalink Reply
tduncandesign
I have run into this again today on a new 5.7.3.4 site I just moved off my dev server to Media Temple. With Cloudflare and Rocketloader(beta) enabled, I am seeing the C5 toolbar drop out randomly, which requires logging in again. I've turned off RocketLoader and it seems to be stable now.

eta: Spoke too soon. It's not stable.
jdch replied on at Permalink Reply
hi