Elemental theme image-slider.less error: .container-fixed is undefined

Permalink
Hi everyone,
I am a student learning web development. I need to learn a CMS and was told this CMS would be a good start. So far I have installed the CMS, watched some of the intro videos and a play around and been very impressed with the experience. I am now starting to apply this to a real website.

I have started by copying the default theme and placing it into the application directory as per this tutorialhttps://www.concrete5.org/documentation/how-tos/designers/how-to-cop...

In the web browser editor mode, I changed the slider images on the front page and now I am trying to change the height, width etc. I opened themes/css/build/blocks/image-slider.less
and made a change
@media (min-width: @screen-lg-min) {
width: @container-lg;
.rslides {
li {
max-height: 480px;
}
}
}

to @media (min-width: @screen-lg-min) {
width: @container-lg;
.rslides {
li {
max-height: 350px;
}
}
}

whenever I try to save I get this error
NameError: .container-fixed is undefined in [location of my file] on line 12, colum3
11 .ccm-image-slider{
12 .container-fixed();

Now I looked at the origianal file located within the concrete directory and tried to make the same change and I also get the same error there as well.

I have no idea what would be causing this to happen.

Kind regards
ArchaicLord

View Replies: View Best Answer
HardOne replied on at Permalink Reply
HardOne
I can't reproduce your problem. Actually I can't even imagine, that your problem is caused by changing a single value.

For me it looks like your editor encodes the image-slider.less with a BOM, causing the LESS compiler to fail silently. You should try saving your file as utf8 without BOM and see if that solves your problem.
ArchaicLord replied on at Permalink Reply 1 Attachment
Thank you for the reply.
I am using Sublime Text 3 as my editor. I installed the Less2CSS compiler.

When I created the database for this site I used utf-8_unicode_ci encoding. I figured this would be the best option.

In Sublime I forced it to safe everything as uft-8.
I have attached an image so you can see.

I tried for arguments sake to save this file with another type of encoding but it wouldn't accept any.

Edit ****
I am developing on a Windows 7 machine. I just realized when I created the site I forget to change the file permissions.
I have just deleted and started the site again. Gave my account full access within the windows security permissions for each folder mentioned on the install guide.
This doesn't seemed to have made any difference either.
HardOne replied on at Permalink Reply
HardOne
Maybe you'd like to try a simple text editor like notepad++. The problem is definetly within your software and not within concrete5.
ArchaicLord replied on at Permalink Reply
OK so I installed Notepad++.

The file saved because it wasn't being compiled.
As soon as I try to compile it that is when I get the errors.

I installed WinLess and put the whole site I am trying to build through that. I found a staggering amount of other errors being produced from that process which seem to relate to the same problem I am having in this current file.
HardOne replied on at Permalink Best Answer Reply
HardOne
You do not have to compile LESS files.