Failed upload; "broken package" message

Have been attempting to work with Concrete5, with GoDaddy as my web host. I am new to this, and the process (due in large part to inadequate documentation for the particular interface of Concrete5 with GoDaddy) has been maddening - obstacles at every step.

Current obstacle:

- Manually downloaded a Theme purchased on the Concrete5 marketplace
- Attempted to upload to /packages in GoDaddy web root. Uploading the unarchived folder appeared impossible (unless I were to destroy its directory architecture by uploading each document individually)
- Uploaded the zipfile, and extracted the file within GoDaddy.
- Returned to my domain on Concrete5 > Dashboard > Extend Concrete5 > Add Functionality: the theme_hi_vis appears under Awaiting Installation with the message: Unknown Package (v.0.0.), Broken Package (handle theme_hi_vis).


1 Attachment

View Replies: View Best Answer
Juha replied on at Permalink Reply
Which theme it was? Did you make sure it's compatible with your version of Concrete5?
mhawke replied on at Permalink Reply
The Hi Vis theme is compatible with 5.5 -> so that shouldn't be an issue.

It sounds like the directory structure inside the packages directory might not be correct. Can you list the files that are in your theme folder?

It's also possible that there are remaining issues with GoDaddy. Some of their servers return incorrect values to very important server variables so I have sworn off any client that insists on hosting on GoDaddy
syssoyeva replied on at Permalink Reply 1 Attachment
Thank you. I have the 5.7 version of Concrete 5. Looking at what I purchased, it is indeed good for — - presumably this is the problem?

I've attached a screen shot of what you can see in the packages file, one level in. Does this answer your question, or do you need more detail?

Thank you!
mhawke replied on at Permalink Best Answer Reply 1 Attachment
I'm sorry to tell you that the theme you bought is not compatible with version 5.7. This is probably why you had to upload it manually and fight to install it. Themes that you purchase can be installed directly from the marketplace in a few clicks IF they are compatible. I would request a refund from the developer because they are all aware of the confusion between 5.6 and 5.7.

See attached screen capture for the warning where you need to choose your version.
syssoyeva replied on at Permalink Reply
Thank you for your generous help!