My Custom themes are not viewable in Dashboard's theme selection.

Permalink 1 user found helpful
I am unable to view and there by install my custom themes under dashboard. I've tried numerous tutorials with no luck and even tried copying one of the default themes and changed the name in each of the file types to see if it would show up as a new but duplicate theme. I believe my template is written correctly.

After uploaded my theme folder to the /concrete/theme folder on my server then check to see if it's available as a useable theme. No dice everytime. I've tried this on a linux server on both godaddy and ipage.

I've also tried uploading and unarchiving using the server's tools. All of my template work is done in Dreamweaver CS5.

I have attached the theme if anyone would care to see if I'm totally missing something. It's a first draft but I believe it should still be sufficient enough.

1 Attachment

View Replies: View Best Answer
anchoredbutterfly replied on at Permalink Reply
anchoredbutterfly
wilkinsdesignstudio replied on at Permalink Reply
Hmm... Those are actually two of the tutorials I had used to create my files. Neither one worked.

I'll review the tutorials to see if I missed something.

My themes are not being recognized by dashboard right now. Is there an specific item that would cause this? Would someone mind uploading my files to see if they work for them? If it doesn't it's obviously my files and if it does work it's something with my server settings or how I'm uploading the files to the themes directory.

Thanks for the input!
julia replied on at Permalink Reply
julia
Hi ya, The most common problem is with the folder name--it should not have spaces or uppercase letters.

Here's the theme guidelines for submitting one to the marketplace--I suggest going though this list and make sure your theme hits on everything.
http://www.concrete5.org/documentation/developers/system/submit-the...

Rather than going through tutorials again, you could compare the files in any of the core themes with your theme's files to see where you might have gone wrong. Or download a free theme from the marketplace and compare it to yours.

Good luck!
Steevb replied on at Permalink Best Answer Reply
Steevb
Upload your theme to root/themes folder, not concrete/themes.

'thumbnails.png' should be 'thumbnail.png'

Put all the files (default.php, default.css, etc) in the 'BRK-ART' folder. Then put the 'BRK-ART' folder in the root 'themes' folder.
julia replied on at Permalink Reply
julia
Good advice from 55webdesign. (Hey 55, I granted you some badges just now. Enjoy.)
Steevb replied on at Permalink Reply
Steevb
I was going to mention uppercase, bit tired...

Thanks for the badges
wilkinsdesignstudio replied on at Permalink Reply
Something so simple... I've been beating my head against a wall for the past 3 weeks and it was because I was putting it in the wrong folder. Well thanks, I guess misread one of the tutorials somewhere along the way.
wilkinsdesignstudio replied on at Permalink Reply
I'm going to try each of those but I wanted to first off say this is probably best constructive help forum I've ever seen. Hats off to the users! Thanks!
mkly replied on at Permalink Reply
mkly
you should put in in /themes not /concrete/themes

name the folder with an underscore /brk_art

your need view.php which is a template with
<?php print $innerContent; ?>

in it. that's used for single pages and some other stuff.

its probably permissions. after correcting the above go to
http://www.example.com/themes/brk_art/default.png

if you get a forbidden then its perms.