trying to get background color to entire page

Permalink
I'm trying to get a background color to the whole page, i.e. blocks and borders both, throughout the whole site. I'm using a Plain Yogurt theme. I don't know a thing about html but I have this line in the main.css:

body
/* customize_background */ background-color:#f2e19f; /* customize_background */ padding: 0px; margin: 0px; }
img {border: 0px}

Is there something wrong here? I got there through this path:
Files Manager>root>concrete>themes>default>main.css

View Replies:
tallacman replied on at Permalink Reply
tallacman
try:
html body {
background-color:#ff000;
}


red is my favorite color.
Wendy replied on at Permalink Reply
Tallacman, This is what I've got:

[/* HTML Tag Redefinition */
html, body {height: 100%; }
body{ background-color:#f7e9af;}
/* customize_background */ background-color:#f7e9af; /* customize_background */ padding: 0px; margin: 0px; }]

Is something wrong here? I still don't get the background color. There's some duplication from a previous effort. Is this the main.css file my theme is using or am I in the wrong place? I also tried to change the header space from 64 to 0 and that didn't make a change either. Please keep this simple, like loud and slow in English. Thanks.
jshannon replied on at Permalink Reply
jshannon
Wendy --

What you posted your second time around should be working. It's odd that it's not (there's some invalid stuff, but that'll get stripped out).

HOWEVER, there's a much better way to go about this. See the /* customize_background */ tag in the original? That's c5-unique comment for customization. Go to your dashboard -> Pages & Themes -> Customize (of your currently-chosen theme, which is highlighted). You should then be able to click on the square before "Background" and get a color-picker to choose from. Change the color, save it, and go back to the homepage.

I find that CSS files get cached a lot so you might have to restart your browser. (You can also open the HTML, click the main.css file link, and reload that manually.).

James
Wendy replied on at Permalink Reply
jshannon, I discovered the Pages & Themes> Customize Theme option early on, almost a year ago but I've never been able to get the background to take. It shows up correctly in the Customize window but when I go back to the website, it's always white again. Any ideas? I've cleared the cache in Sitewide Settings and even disabled the Basic Cache. I'm not sure how to
"click the main.css file link and reload that manually."
But, I'd be grateful for any help.
Wendy replied on at Permalink Reply
jshannon, I discovered the Pages & Themes> Customize Theme option early on, almost a year ago but I've never been able to get the background to take. It shows up correctly in the Customize window but when I go back to the website, it's always white again. Any ideas? I've cleared the cache in Sitewide Settings and even disabled the Basic Cache. I'm not sure how to
"click the main.css file link and reload that manually."
But, I'd be grateful for any help.
Wendy replied on at Permalink Reply
jshannon, I discovered the Pages & Themes> Customize Theme option early on, almost a year ago but I've never been able to get the background to take. It shows up correctly in the Customize window but when I go back to the website, it's always white again. Any ideas? I've cleared the cache in Sitewide Settings and even disabled the Basic Cache. I'm not sure how to
"click the main.css file link and reload that manually."
But, I'd be grateful for any help.