A first encounter with Concrete5 and a few problems

After days of evaluating CMSs, I thought I’d spend the day testing C5. Overall, C5 shows much promise, but so far in my hands it’s not quite ready for prime time.

Rather than a local install I choose a web install, so others can also evaluate it. My host is at PHP 5.3.17. C5.7 requires 5.3.3. or greater. Looking at C5’s recommended budget hosts, I chose webhostinghub. I signed up for a test account and then used Softaculous to install C5, with no data since I can add my own. That was a mistake. The result was one page and about ten empty blocks. An attempt to do the simplest of things, like add a banner, was impossible for someone new to C5 like me.

So I removed the install and reinstalled with data. Much better, the Elemental sample site looks excellent.

Test 1. Edit the “Easy to Edit” block. Surprise. No in place editing. Instead a modal dialog appears, titled “Edit Feature.” The text Paragraph has 20 blank spaces prepended, so you have to first remove them. Inserting test text goes well, except for the missing editing toolbar. There is none! No way to bold, do italics, set links, etc. In editing the sample text, two carriage returns gives a blank line. But after clicking Save, the text is all smushed up into one paragraph. This test was a total failure.

Test 2. Edit the upper image. A click on it and Edit Block brings up “Edit Image Slider.” Now suppose I want two images of my choice. A click on the single image brings up “File Manager.” Now how do I select two images? It can’t be done. The page will not allow checking two images. As soon as the first one is checked, it returns to “Edit Image Slider” with just the one image. Eventually I figured out the File Manager is poorly designed. The checkboxes are useless for selection. Instead, in Edit Image Slider you have to scroll down to another Entry. I also did some test text editing. Now there is an edit toolbar. But the editor behaves very poorly. Pasting any text causes it to jump to a new line. For example, if you copy one word and paste it to another place in the sentence, the sentence is now split into three lines: what was before the word, the one word, and what was after it. Most unpleasant. This test was a half failure.

Discovery: Save feature – Saving instead of publishing causes a “Page is Pending Approval” dialog to appear every time the page is viewed, such as when leaving edit mode. Well, this is APITA. One has to continually hide it. How about a discrete icon that can be toggled on and off?

Test 3. Edit the “Presenting Your Business” block. Surprise! This brings up in place editing, with the edit toolbar. This editor also has the “sentence splits into three pieces” bug described earlier. It can’t be used for serious editing, unless you go back to the first grade and do very, very simple things.

Test 4. Edit the three project images block. This brings up the Edit Page List dialog, with number of pages to display = 3. Now how to I change that to 4? Can’t be done. Changing 3 to 4 results in no behavior change after Save. Examining the dialog shows no way to add, change, move, or delete the Included Pages on the right. Closing the dialog and exploring the Pages and Dashboard led to no clues on where this sitewide block might be defined. This should be easy to find. It appears to be a Portfolio Project page type. But how can a page type be on a page? Makes no sense. This test was a total failure.

Then I figured out there were only 3 pages of that type on the site. Changing 3 to 4 has no effect since there are no more. But if a user enters 4, they are expecting to see a fourth page. C5, if it wants to be known as easy to use, should indicate there is no fourth page.

Test 5. Edit the “Contact Us Today” link. This is near the bottom of the page. Clicking on the Pencil icon does put the page into edit mode, but it also scrolls the page to the top. Poor usability. After one laboriously scrolls down, we edit the block. Clicking on the Contact Us Today image give no indication if it has a link or not. Poor usability. Clicking on it also gives no indication it is selected. Clicking on it and then on the link icon in the toolbar gives only two options: Insert Link and Unlink. What about Edit Link? When I’ve added a link, the two options are still the same. The first, Insert Link, is then wrong. You can't insert a link if the image already has one. You can only edit it or delete it. Poor usability. Worse yet, if one has already entered a link, it can’t be edited!!!!! If you made a one character mistake, that can’t be changed. Instead, you have to insert the entire link from scratch. This test was a half failure.

Test 6. Edit the “Customizable Footer Area”. Clicking on this opened the small edit choice somewere, apparently, but I can’t see it. The entire page is dim, except for the block I just edited, the one with Contact Us Today. The page is hung. The only way out is back page. Apparently still in edit mode. Did a page refresh, then tried to edit the Customizable block. This time it worked. Scary that C5.7 could be so brittle. This test was a half failure.

Test 7. Let’s see what’s in the Dashboard. Hmmm, let’s explore System Settings. I don’t want URLs like “http://sawneespring.org/Test2_57_data/index.php/services” so let’s turn Pretty URLs on. After turning the check box on and clicking Save, guess what? The left window doesn’t go away. It stays there! No indication anything has been saved! Worse yet, the home page URL is okay: “http://sawneespring.org/Test2_57_data/” but the tab pages are not: “http://sawneespring.org/Test2_57_data/index.php/services.” This test was a failure.

Verdict – C5.7 is firmly in alpha. One can find a new problem every few minutes, with no end in sight. The design shows great promise, but the execution is not yet there. I am extremely disappointed.

Then from within the test site I clicked on Extend Community, registered, and logged in. My, my, only 7 themes total. Looking at the add-ons, in All Items we see 9 on the first of 5 pages. That’s a total of 45 or less. Looking at the first 9, they are trivial. Who wants to Raptorize a page? Who doesn’t know how to do a redirect? What good to anyone are “comments that show only in edit mode”? Why do you need an add-on for a Like button? One can do that with an image and very little code.

One site I’d love to use C5 on needs many image gallery pages, so let’s look at the Image Galleries add-ons. Surprise. Choosing Image Galleries in the dropdown has no effect. To me that means a bug or a deliberate bug to hide the fact there are none. To be fair, it appears that choosing any item in the dropdown has no effect.

So I tried version via another Softaculous install with data. This was even worse. Going into edit mode on the home page, we see each block bordered with red dots. Each block has something like “Add to Sitewide Site Name.” Clicking on any block does NOTHING, unlike in C5.7. After several minutes of justified frustration and disgust, I finally noticed that the upper left hand corner of each block had a tiny dark gray mark about 1/4” high and 1/32” wide if you hover over the block. Clicking on the gray mark of the “Welcome to Concrete5!” block brings up a menu. But it’s half hidden since some of it’s off the browser window, and thus offers cryptic selections like ock, rom Clipboard, ack. Poor usability. Choosing ock, we find it must mean Edit Block. But then up comes not a dialog, not in place editing, but a new page of unformatted html.

For the “Add To Sitewide Site Name" block this is one big mess. Blue icons are over text. Looking at the page source for the CSS that’s not being applied, what do we find? “$(window).css('overflow', 'hidden');” Well, the css for this window is simply not there. For this reason no block on the page is editable, unless you torture yourself and find a block where you can hand edit the html, since the nifty edit toolbar is nowhere to be seen.

Soldering on, I tried to edit the image slider in the demo on Softaculous. Maybe that’s a good install. Clicking on Save (I think) provoked an error dialog that was so long it scrolled off the bottom of my 1600 pixels high screen. It began with “An unexpected error occurred. Call to a member function getInstance() on a non-object < Back to Home Save Changes Page Properties SEO Attributes Caching Permissions Design Versions Delete Dashboard Sitemap Files Members Reports Pages & Themes Workflow Stacks & Blocks Extend concrete5 System & Settings Exit Edit Mode Settings Add Dashboard Add Page SitemapFull”. For those investigating this crime, here’s the URL:

Verdict – C5.6 is a complete disaster. I suspect this is a bad install due to the host or Softaculous or both. For example, the shared server may have an old version of PHP. Checking this we find 5.4.35. Should be okay.

The problems I encountered today were mostly due to lack of testing or usability testing. Every one of my problems should have been discovered and fixed long ago, before getting to the fancy features. It doesn’t matter how efficiently you can accomplish a task if you can’t accomplish it at all.

Perhaps someone can point me to a demo installation of C5 that works? There is so much promise here.

View Replies:
mesuva replied on at Permalink Reply
Your 5.6 install sounds completely broken.
5.6 is a very polished version of concrete5 and has been heavily tested and bug-fixed.

My suggestion would be to either setup some test installs locally or (since you've said you want others to be able to evaluate things) to install it on your host by uploading and unzip the install zip and going from there.
jackh replied on at Permalink Reply
Re: "Your 5.6 install sounds completely broken."

Thanks, but neither are my installs. Where did you get "your"? The 5.7 install was by a host recommended by C5. The 5.6 install was by Softaculous, who provides the install software for the C5 affiliate.

It would seems to me that the C5 team would find it in their best interests to duplicate my problems and see where their affiliate went wrong. And note that many of the problems are not due to a broken install, but buggy software or poor usability.

I think it would be very useful for the C5 team to provide demos that worked. Perhaps they are out there and I've missed them. A search on "demo" on the C5 site turns up nothing of use. I had especially hoped to see Demo in the C5 website header or footer, like so many other software sites, but it's just not there.

I wonder how many other people have encountered problems similar to mine, and simply gave up and left. I haven't' because I see so much beautiful design and promise.
mesuva replied on at Permalink Reply
Can you post a screenshot of the place where it has the cut-off text - 'ock, rom Clipboard, ack'?
jackh replied on at Permalink Reply 1 Attachment
Certainly. I took a snap of my entire screen, so you can see two bugs in two browser windows, complete with urls and all the context the entire window provides.
mesuva replied on at Permalink Reply 1 Attachment
Something is definitely going weird with your right hand screenshot, you should be able to click anywhere along the area to bring up the popup menu.

I'm wondering if this is a Firefox issue, or maybe a particular version of Firefox (I just tested then and didn't have any issues using Firefox with 5.6.x)

Perhaps try using Chrome and see if there is any difference?
jackh replied on at Permalink Reply
Thanks again. I just tested 5.6 in Chrome. It doesn't have the problem. Nice to see at last how it should work.

Checking my Firefox version, it was 33.1. It immediately updated to 33.1.1, but the problem has not gone away.

Trying to reproduce the 5.6 error on the left half of the image I sent you, I could not in Firefox.

I'm now testing two different versions of C5 on two different hosts, so hope I'm not getting mixed up on what I'm reporting to you.

Thanks for the help!
mhawke replied on at Permalink Reply
I completely share your views on 5.7 still being in alpha. Many people have expressed this but apparently the ship has sailed.

5.6 is very stable but you need to know that sites built in 5.6 cannot be upgraded to 5.7 and very few of the add-ons built for 5.6 have been re-tooled for 5.7 as you noted above.

One thing you need to keep in mind is that concrete5 is not the same thing as WIX or Squarespace. It is not meant to be a drop and drag website builder even though the initial UX might lead you to that conclusion. The reason I love c5 is because I can develop a website for my client that has just the right amount of creative control so that they can easily and consistently edit their content but not enough control to destroy their website. It is extremely powerful under the hood but it takes some digging to utilize that power. I find that the more experience you have with other CMS products or with coding in raw HTML, the more difficult time you will have 'getting it' at first.

My understanding of concrete5 grew quickly after I started building my own blocks for my clients. I would suggest installing a free add-on called Designer Content that allows you to create your own structured content.
Rad replied on at Permalink Reply
I have recently just dived into C5 so obviously, I'm still learning my way around. And from what I've seen in the forums, 5.7 has it's share of issues. However, I never understood it to be a case of "5.6 cannot be upgraded to 5.7" as you said.

Is this a temporary thing or is 5.7 such a complete revamp that I'll have to rebuild the site once it's stable enough to go to it? Other option being staying at 5.6 forever?

Would love to know now before I swim out any farther!
mhawke replied on at Permalink Reply 1 Attachment
On the page where 5.7 is downloaded there is clear warning that there is no upgrade path (see attached screenshot).

That being said, some of the heavy-hitting developers have discussed the issue and it seems that there are significant barriers to creating an upgrade script that would be trouble-free. As I understand it, if the previous add-ons had been built with such upgrading in mind, then building an upgrade script might be plausible but the original developers of these add-ons were not required to build in that 'export' functionality.

Please correct me if anyone has more intimate knowledge of the issue.
Rad replied on at Permalink Reply
I hadn't even looked at that. Was just picking the 5.7 issues up from reading here in the forum. Guess I'm going to have to make a decision on whether to stay with C5 or not. Thanks for the reply and the info.
JohntheFish replied on at Permalink Reply
Whilst c5.7 is new and shiny, c5.6 is mature, reliable, faster, better documented and much better supported in the marketplace. There is also long-term support for 5.6. So for an existing site that is stable there is no reason to rebuild in 5.7.