Access denied error upon edit

Permalink 1 user found helpful
I'm wondering if anyone else has run into this and, if so, what the resolution is.

I added a page for my client which they later tried to edit and could not. I was able to reproduce the problem he described without fail.

We navigate to the page, click the "edit page" button, click the content area and select "edit." The editor overlay-window opens but is empty except for the message "access denied." The page is now uneditable.

We're using one admin log-in so user permissions aren't the issue. Thoughts? Thanks in advance.

liberalmark
View Replies:
jgarcia replied on at Permalink Reply
jgarcia
you said that you "later try to edit" the page and cannot. do you mean that you login later under the same username and try to edit and you get the error? or do you mean that you wait a little while (without any activity) and then try to edit? if the latter, it may be that you session timed out. if it's not that, can you provide a little more detail. what are the exact step you go through to duplicate the problem.

the only instance in which something like this occur is if i let my browser site for a while with no activity (while logged in) and then come back later and try to edit.
liberalmark replied on at Permalink Reply
liberalmark
Good call, but this doesn't have anything to do with sessions. My client mentioned this days ago and since that time I've even restarted my computer, so everything in that session has been destroyed. I've cleared cache, history, etc. and still no luck.

So, in short, logging out and back in again still produces the same results.

Regarding the steps:

1) I created a page.
2) My client tried to edit a week or so later.
3) They reported the access denial.
4) I logged in and tried to access the page with the same results.
jgarcia replied on at Permalink Reply
jgarcia
i've never seen this issue occur. maybe someone else has and can give some more insight. until then here's some ideas you may or may not have tried already:

-Try creating a new user and assigning that to the administrators group and logging in as that user to edit.

-Try adding the administrator to the administrators group

Other than that, I've got no clue cause I've never seen that before. One more question though - have you tried adding a block other than the content block? Will it let you do that?
iravanchi replied on at Permalink Reply
iravanchi
I ran into the same problem with my home page now. Let me describe more what I've tried:

1. The problem is in my 'Home' page. Other pages seem to be working fine. (Haven't tried too much, but could edit content in other pages when I tried)

2. The problem is with SOME of the areas on the page, not all.

3. The problem is NOT limited to Content block type. AutoNav could not be edited too.

4. Adding new blocks is possible. But the newly added blocks can not be edited immediately.

5. I did a 'Move' operation on the blocks of the page before the problem is introduced. I don't know if the problem is associated with that or not.

6. No operation can be performed on the problematic areas (not only edit), I mean, when you choose 'Set Custom Template' you get the access denied too.

7. Deleting of the blocks are also possible.

Any ideas?
Any solutions?
JCinch replied on at Permalink Reply
Is your client on a group?

Go into your administration panel and click Users and Groups.
Now, click on the clients username.
At the bottom of that page, you should see Groups.
Now, click add to group. Add him to the administrators group.
See if that works for him.
iravanchi replied on at Permalink Reply
iravanchi
In my case, I'm using the admin user which should basically have permission to do anything, and haven't changed anything in the users / groups / permissions.

This is a false 'access denied', and I suppose that's a bug.

Haven't tried the 5.3.0 yet, I'll check and post back.

Another thing is that the issue is in my Home page. If it was any other page, I would have removed and re-created the page!
iravanchi replied on at Permalink Reply
iravanchi
I've upgraded to 5.3.0 and I'm not seeing the above issue any more in what I'm working on.

Haven't tried comprehensively yet thou...
glockops replied on at Permalink Reply
glockops
I am experiencing the same problem on my site running 5.3.1.

The "Access Denied" occasionally shows its head when editing blocks and ALWAYS appears when accessing the properties or exiting edit mode.

Running a brand new test site as the administrator and only user.
glockops replied on at Permalink Reply
glockops
The problem appears to be related to my custom template. So for anyone encountering this error, check your template files.

In my case, using an included template made the error go away - so I'm off to fix my template.

If I figure out what specifically caused the problem I'll post again.
glockops replied on at Permalink Reply
glockops
I found what in my template was causing the access denied error. I have an accordion menu script (a javascript by Ryan Stemkoski) that allows my side menu to expand when clicked - turns out that including a file containing the triggering divs (no js or any code except html) caused the problem. Oddly enough, including the javascript file didn't cause any problems by itself.

My solution is to provide different content while in edit mode (thus removing the offending "trigger" divs from the include).

<?php 
global $c; 
if ($c->isEditMode()) {  
  echo 'Message / Different Content here';
  exit();
} 
?>
... Menu to display when out of edit mode (Regular HTML)...


Hope that helps anyone else in my situation.
lugor replied on at Permalink Reply
lugor
Hi there,

I got the same problem.

Have not figured out in detail what the real problem is.

But as a workaround I found out that
choosing the "design" link to call the "set block styles" dialog and then using the "reset"-button seems to fix the problem.

After that I can edit the block again.

I am not using any block styles at all so this is pure voodoo.

Problem occurred using area splitter with 5.4.0.5. and an alias scrapbook block.


best regards

Stefan
nbruley replied on at Permalink Reply
I had the same issue after installing concrete 5.4.1.1 using simplescripts to install to a subdirectory on Bluehost. I could not edit anything or do anything. Sometimes clicking to edit something just immediately signed me out. The first time this happened, I uninstalled Concrete 5 and tried again. I noticed when uninstalling, the files in the files/cache folder remained, and as long as those were present, I got the error. I reinstalled to a subdomain, deleted the cache files, and things seem to be ok-- on that site. I installed a new site to a subfolder and I had the same issue, but even deleting the cache files didn't solve it. I didn't get the access denied error, I just get kicked out of the site... I think I will reinstall again to a subdomain instead of a subfolder and see if that fixes it.... this is getting to be cumbersome...
nbruley replied on at Permalink Reply
After re-installing to a subdomain like last time, it seems to work. Weird. Maybe it has to do with the fact that my primary domain is a Concrete5 website also, and perhaps the htaccess files conflict...
jamesleech replied on at Permalink Reply
jamesleech
I just had this error with a superfish menu pasted from the global scrapbook. I deleted the block and added it again which seemed to fix the problem.
Judder replied on at Permalink Reply
Judder
We have just spent a number of hours on this problem, with again a particular page that all of the editing boxes produced 'Access Denied' when trying to be edited.

It turns out that as the permissions look-up on each block is done with an Ajax request, so therefore if there is a 404 on your page (missing image, javascript file etc.) then this Ajax call fails after that point.

What this means is that the default text ('Access Denied') is displayed because no better response can be obtained.

If you fix the 404 issue, we reproduced this issue, then this ensure the Ajax call works, and the permissions work again.

Painful issue to diagnose but easy to fix!
suastiastu replied on at Permalink Reply
suastiastu
I have a very similar problem. example the first page of users is fine - if I hit next then I get Access denied. I am the administrator. I can't edit any page or set any permissions. I'm not clear what might be causing the ajax failure.
safetyfirexperts replied on at Permalink Reply
Entry into Text Block is limited to a fixed number of characters. If you exceed the limit, this access denied shows up. Solution is to add another Text Block and continue the writing without seeing the access denied. Hope it helps some one.

# concrete5 Version
Core Version - 5.7.5.2
Version Installed - 5.7.5.2
Database Version - 20150731000000