Cannot Add Blocks

Recently, the "Add Block" feature has stopped working. You can select "Add Block", which opens up the "Add block" dialogue. When I try to select any block, it opens up the new window, but remains blank, and the thing spins in the center and doesn't stop.

From what I can tell, it looks like the url address is incorrect.
My concrete installation The URL that shows up when I select a block is: ""
It appears to be missing "/index.php/tools/required", such that the correct address should be something like ""

I can still edit blocks just fine, but I can't add blocks.

I didn't install any blocks or themes or any other changes that coincided with this problem. It just happened all of a sudden. I appreciate any help.

View Replies: View Best Answer
binarytide replied on at Permalink Reply
I'm having the same problem myself. any solutions would be greatly appreciated
drunkndragon replied on at Permalink Reply
I also have the same issue, I have tried multiple times same result. I can edit blocks, just fine but again cannot add.

I have tried unistalling and reinstalling.. I deleted the DB.. I even went as far creating a fresh directory to install it in. It is the same no matter if it is a default or downloaded theme..

Help please..:)
zenox replied on at Permalink Reply
I'm having the same problem. Are any of you using dreamhost? I'm wondering if its a problem with their one click installation?
engineerable replied on at Permalink Reply
Yes, I use dreamhost, but the problem arose suddenly with sites that have been in use for 1+ years, and happened on 2 of my 4 installs. I recently created a new site using the one click install, and it does not have this problem.
zenox replied on at Permalink Reply
I was able to resolve this by modifying the `/concrete/elements/block_area_add_new.php` file. Find the location where it has: `href="<?php echo REL_DIR_FILES_TOOLS_REQUIRED?>/add_block_popup.php?` and modify it to be `href="<?php echo REL_DIR_FILES_TOOLS_REQUIRED?>//add_block_popup.php?` (double slash).

While I didn't investigate why it's not working (I just needed to get it working ASAP), I believe its something to do with some kind of javascript pagespeed library.

If you make the change, I would suggest putting it back, once you are finished, as I really know nothing about the concrete codebase. Also I need to make a similar change to `/concrete/elements/files/upload_single.php`.

Hopefully this helps you get on your way!
zenox replied on at Permalink Best Answer Reply
Also, now that I'm thinking about it, did you enable the 'Page Speed Optimization' option in dreamhost? I bet that is the culprit.
engineerable replied on at Permalink Reply
That Solved the Problem! I un-enabled "Page Speed Optimization", and now I can add blocks! I must have enabled "Page Speed Optimization" at some point, and didn't make the connection to the problem.