[SOLVED] Adding a Page - Setting Page Name and Location

I don't seem to able to see where or how I set the new page's name and location.
The steps I've taken:
Click Add Pages button
Click "Page" -> This takes me to the new page where I can add blocks and content.
Click Page Settings -> Composer
This shows a bar at the bottom of the page with buttons for Discard, Save, Edit Mode and Publish. No options anywhere to change page details. If I click Edit Mode it takes me back to the page edit where I would add blocks or content. If I try to exit edit mode I get a message telling me that I haven't set a name or location with a link on where to do this. Clicking the link takes me back to the Settings -> Compose point as described above.

How do I set the page name ("About Us") and set it's location?

Many thanks.

UPDATE: I'm an idiot, I forgot to wrap everything with
<div class="<?=$c->getPageWrapperClass()?>"> </div>

All fixed.

View Replies:
webporter replied on at Permalink Reply
Thank you, thank you, thank you!

Argh! My head has been spinning in circles trying to figure out what was conflicting in my template with c5 because I couldn't see the Composer Settings either. I totally missed wrapping my page in <div class="<?php echo $c->getPageWrapperClass()?>"> but it worked - hurray!

I didn't follow the steps in the docs guide when converting my template to a c5 theme - my bad. Here's a link for others:

I'm just going to put some keywords below to help anyone else who has this problem find this post...
can't save new page
can't add new page
how do I save a new page
can't see composer settings
can't see page settings
composer settings is blank
page settings is blank

That should do it :)
- Mal