Admin accounts can't move/copy pages in dashboard sitemap

Permalink
I have a site (built with 5.5) that has advanced permissions enabled. The site Administrator group users have all permissions available applied, but they are unable to move pages around (click and drag) in the dashboard sitemap. They are shown the message:

You do not have sufficient privileges to add this page or these pages to this destination.

I have the super user account, and can move pages around as usual.

The administrators can do everything else you'd expect an admin to be able to do in the dashboard etc.

Has anyone else come up against this issue, or able to suggest any fixes? (Beyond updating to 5.6, although this is in the pipeline...)

drbiskit
View Replies: View Best Answer
moth replied on at Permalink Reply
moth
Me too.

Can't seem to allow administrators to do this 5.5.2.1.
drbiskit replied on at Permalink Best Answer Reply
drbiskit
UPDATE - Got this working. It was being caused by sub-page permissions not being correctly configured.
pixo replied on at Permalink Reply
pixo
Do you mind if I ask what you did to fix this? I'm seeing the same issue on a site.
drbiskit replied on at Permalink Reply
drbiskit
Yep sure. It was being caused by an advanced permission setting ('Add Sub-Page') in the page that was the parent/destination for the moved page.

So - if I had this:

page 1
page 2
- page 2a
- page 2b
page 3

And wanted to move page 3 to be a child of e.g. 2b, I needed to go to the permissions for 2b, and make sure that 'Add Sub-Page' had the 'Administrators' group added.

NB: I have now upgraded this site to 5.6.1.2, and I can't honestly remember now whether I fixed this before or after the upgrade. I have a feeling that it was after the upgrade, and the issue became visually more apparent due to the new UI for the permissions controls.

Anyway - Hope that helps!?
pixo replied on at Permalink Reply
pixo
Thanks for your reply. What I ended up finding late yesterday is that the Events add-on was what was causing the permission issue. Once I upgraded to the latest release it fixed that bug.