Administrators cannot add new pages

Permalink 3 users found helpful
Hi all,

Recently, I installed Concrete5 and activated advanced permissions.

I then created a new administrator. Oddly, this new administrator cannot add new pages.

When I log in as the new administrator, the "add page" button on the top left of the c5 bar doesn't even appear.

Any advice on how to confer upon this new administrator privileges to add new pages would be much appreciated.



View Replies: View Best Answer
ScottC replied on at Permalink Reply
check out the screenshots here, but select the homepage, not dashboard.
chizeng replied on at Permalink Reply
Thanks for the screenshots. When I confer upon admins all permission settings for the home page, however, there is still no add page button for the new administrator.
cleverington replied on at Permalink Reply
I have exactly the same issue. I have advanced permissions. I have the page set up with the administrators group with full access, yet they still cannot add a page.

When in site map,clicking the page and selecting 'add page' returns an access denied message.

When visiting the parent page, there is no 'add page' button.

Any ideas??
cleverington replied on at Permalink Best Answer Reply
I've solved it.

Goto your home page and click the permissions button.

Make sure Administrators have full rights.

Then change the 'Currently Viewing' option to 'Sub Page Permissions' and tick which page types your administrator is allowed to add.

Click 'Save'

Problem sorted.

This is a great feature as you can limit the 'design' freedom of the users, it's just that it was a little too hidden for my liking :-)
Rushing replied on at Permalink Reply
Thank you! I was having this issue too. Agreed that it's a great feature, but a little too hidden. Of course, now that I know it's there, I won't forget it. I guess that's just how it goes with feature/option rich apps sometimes.
MrNiceGaius replied on at Permalink Reply
Wow, it's right in front of my nose !

I was so confused from this menu...

I think the reason it is confusing is because when you click on the button labeled "Permissions" the dialog window that opens up has the heading "Page Permissions" ...

then the 'Currently Viewing" drop down menu says "Page Permissions" ...
A slight miss-communication in design because to have the main heading be "Page Permissions" but then have a section titled "Page Permissions" is confusing ... or at least not 100% intuitive:)

What if the main heading was just "Permissions"?
keep the heading "Page Permissions" and change the select item label to something like 'Currently Viewing: Access Permissions, Sub-Page Permissions, etc'
abra100pro replied on at Permalink Reply
Funny, I have several new installations of and only one of them had the issue, that - without advanced permissions set - the administrators had not the right to add subpages! strange.

I then changed to advanced permissions and did what you suggested and it worked.