Advanced permissions & file manager access

Hey there,

I have a group of site authors and whenever they try to add an image or a file they get the message "Unable to access the file manager." It looks like there have been quite a few questions around this topic, but none of the answers have done the trick for me yet.

Under the advanced permissions scheme, the site authors are assigned the same permissions as the admin for dashboard->file manager. All the pages beneath the file manager inherit it's permissions (although I have set them to overide too and that made no difference).

I feel like that should be all that needs to be done, no? All advice appreciated.

View Replies:
hursey013 replied on at Permalink Reply
In the dashboard, under File Manager there is a tab labeled "Access". Groups needing access to the file manager will also need to be added here in order to get it working correctly. The permissions in this area are specific to the file manager (like whether people can add/edit/delete anyones files or just their own). Hope that helps.
doub1ejack replied on at Permalink Reply
I think I've got that covered. When I click on dashboard->file manager->access it appears to be inheriting the permissions for file manager. That is, the site author group is present with the same permissions selected as for the admin, but they are greyed out. I tried setting the permissions manually, but that didn't make any difference.

Other ideas?
phowie74 replied on at Permalink Reply
I also came across this problem and spent a fair whack of time trying to figure out what was going on setting and re-setting advanced permissions to no avail. Whilst looking around to see where else I would be able to affect file manager permissions I came accross the Access tab.

If you log in as your site administrator you can go to the file manager section in the dashboard and click on the Access tab. Here you can add individuals or groups and set their detailed file permissions.

I hope this is of help to others who are hunting as I was.
kbetker replied on at Permalink Reply
Would you know if this has change by chance in version, or is it right in front of my face? I don't see it and it is driving me nuts. Thanks for any help!
weyboat replied on at Permalink Reply
go to system & settings, permissions and access, file manager permissions, and there you will find the page you are looking for,
you can add groups and users..
kbetker replied on at Permalink Reply
Awesome. Thanks!