An unexpected error occurred.

Permalink 1 user found helpful
So I log in to the site to update it and hit the sitemap and get the following error. This is all Greek to me. I have not added anything outside but to get support I have to pay $125.00/hr. I am not a coder, and even did the site for free for a non profit...

This is where the issue is. If someone is willing to help I will give you access.

mysql error: [145: Table './akmens_cncr1/PageSearchIndex' is marked as crashed and should be repaired] in EXECUTE("select p1.cID, pt.ctHandle from Pages p1 left join Pages p2 on (p1.cPointerID = p2.cID) left join PageTypes pt on (pt.ctID = (if (p2.cID is null, p1.ctID, p2.ctID))) left join PagePaths on (PagePaths.cID = p1.cID and PagePaths.ppIsCanonical = 1) left join PageSearchIndex psi on (psi.cID = if(p2.cID is null, p1.cID, p2.cID)) inner join CollectionVersions cv on (cv.cID = if(p2.cID is null, p1.cID, p2.cID) and cvID = (select max(cvID) from CollectionVersions where cID = cv.cID)) inner join Collections c on (c.cID = if(p2.cID is null, p1.cID, p2.cID)) left join CollectionSearchIndexAttributes on (CollectionSearchIndexAttributes.cID = if (p2.cID is null, p1.cID, p2.cID)) where 1=1 and p1.cParentID = '0' and (p1.cIsTemplate = 0 or p2.cIsTemplate = 0) and (((select count(cID) from PagePermissions pp1 where pp1.cID = if(p2.cID is null, p1.cInheritPermissionsFromCID, p2.cInheritPermissionsFromCID) and pp1.cgPermissions like 'r%' and (pp1.gID in (2,3,1) or pp1.uID = 2))) > 0 or (p1.cPointerExternalLink !='' AND p1.cPointerExternalLink IS NOT NULL)) and (p1.cID not in (5,6,7,8,10,11,12,13,14,15,75,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,43,44,45,46,47,48,49,50,51,52,53,54,55,76,77,78,79) or p2.cID not in (5,6,7,8,10,11,12,13,14,15,75,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,43,44,45,46,47,48,49,50,51,52,53,54,55,76,77,78,79)) ")

View Replies: View Best Answer
mkly replied on at Permalink Reply
If you are talking about a non-profit feel free to pm(private message) me and I would be more than willing to take a look.

You have a kind of serious issue going on with your database.
bmkdesigns replied on at Permalink Reply

Thanks for the offer, just fixed the database. People like you and Mesuva make the Concrete 5 community amazing!! Scratch the message I sent you.

mesuva replied on at Permalink Best Answer Reply
This is an error that can't be solved from within Concrete5, it's to do with MySQL.

If you have access to MySQL through some sort of administration (like phpMyAdmin), you'll need to log into that and find the table PageSearchIndex and run a 'repair' command on it.

If you can't find the repair command, you could just run this SQL against the database:
REPAIR TABLE PageSearchIndex;

I've seen that happen before and it's pretty harmless, just annoying when it does happen.
bmkdesigns replied on at Permalink Reply
It worked like a charm!!! It took me longer to type this THANK YOU than it did for the fix!!

I logged into CPanel, Clicked Databases, and found the one and only database... Clicked repair database. Done, it all works like a champ!! Thanks so much for your reply!!