Auto Nav Options

Permalink 10 users found helpful
I'm trying to create my auto-nav system so that two of the buttons (residential services & commercial services) will not display pages to visitors. Only direct them to sub-pages.

(Like the current wall-mart website only I'm very satisfied with my current top menu nav style :-)

For example I would like visitors to see that I have "residential services" in the menu but when they scoll over that they will only be able to click on "window cleaning, house washing, or additional services."

I'v read a few of the tutrials and tried a number of things but still struggling with this.

FYI I used the scrapbook to insert the same auto-nav on all pages.

Any advice would be appreciated, thanks in advance.

My website is:http://www.clearlycleanwindowwashing.com/...

View Replies: View Best Answer
pixelfish replied on at Permalink Reply
pixelfish
You could look up adding an attribute which would make the main level link go to the first child page.

If this would do just search the forums for 'replace_link_with_first_in_nav'
jordanlev replied on at Permalink Best Answer Reply
jordanlev
Pixelfish is correct. Here's step-by-step instructions on how to do this:

First, create the attribute in your dashboard (you only need to do this one time):
1) Log into your site, go to Dashboard -> Pages and Themes, then click the "Attributes" tab link at the top of the page.
2) Down at the bottom of the page (under "Choose Attribute Type"), choose "Checkbox" from the dropdown menu, and then click the "Go" button.
3) Enter this for the handle: replace_link_with_first_in_nav
And enter this for the name: Replace Link With First In Nav
4) Click the "Add Attribute" button.


NEXT, add the attribute to the appropriate page (repeat this for every page you want to direct to a subpage):
1) Go to the page, click "Edit Page" in the toolbar, then click the "Properties" button in the toolbar.
2) Click the "Custom Attributes" tab.
3) In the "**Add Attribute" dropdown menu, choose "Replace Link With First In Nav".
4) A new checkbox called "Replace Link With First In Nav" will be added to the bottom of that little window (you may need to scroll down a bit) -- check the "Yes" box.
5) Click "Save", click "Exit Edit Mode", and publish your changes.

That should do it!
cavidano1 replied on at Permalink Reply
cavidano1
Thank you for posting this, Jordan. I spent an entire day searching for a way to do this without creating a hack.

This is the most straightforward explanation.

You have save me tons of time.
leinteractive replied on at Permalink Reply
leinteractive
Another option you can do is to (from the Sitemap in the dashboard) add an External Link where you'd like your "empty" nav item to be (a placeholder per say). Instead of putting in an actual URL, simply enter a hash tag # and hit save.

You can add sub-pages underneath that and then your top level item will simply function as a placeholder instead of an actual page.
bennett49r replied on at Permalink Reply
bennett49r
Worked like a charm!! Thanks Jordanlev!!!
casuto replied on at Permalink Reply
Does this work in 5.5? I cannot see the steps after your:

3) In the "**Add Attribute" dropdown menu, choose "Replace Link With First In Nav".
4) A new checkbox called "Replace Link With First In Nav" will be added to the bottom of that little window (you may need to scroll down a bit) -- check the "Yes" box.
5) Click "Save", click "Exit Edit Mode", and publish your changes.

Am i missing something or has this moved to another section?

Thanks.
jordanlev replied on at Permalink Reply
jordanlev
I think in 5.5 there's not a dropdown menu for "Add Attribute" anymore... instead they are all listed on the left sidebar of the "properties" dialog window. They may be stuffed into different categories/folders... try clicking around on that left sidebar thing under the "Custom Attributes" tab.
DanK replied on at Permalink Reply
It does work in 5.5, the steps are labelled slightly differently but if I can work it out anyone can... Once again Jordan comes up trumps, I've been trying to work this out for ages. Thank you!
casuto replied on at Permalink Reply
I have done all of the steps correctly, but i am not seeing it as an additional option with my custom attributes. I have done this successfully on another website but on this one it is not working. Perhaps it is a version issue?

Clear my cache, maybe? Logging out first?
casuto replied on at Permalink Reply
I figured it out. My mistake. I was putting it under the Attributes section for members and not pages and themes. Thanks!
chrismodlao replied on at Permalink Reply
chrismodlao
Thanks jordanlev it works like a charm and seams to be a good alternative.

Chris
TMDesigns replied on at Permalink Reply
TMDesigns
This also works on 5.7